Google Pixel 6 Cellular Signal Issue

Sorry, but it seems the mobile community isn’t done with issues about the Pixel 6. It’s not our fault that we’re seeing such reports. It’s actually good because it tells us many people have already gotten their hands on the phone and are using either the Pixel 6 or Pixel 6 Pro in real life. Just the other day, we learned about the Pixel 6 not charging with low-quality USB-C cables and chargers. That was only after we heard about its incompatibility with the DJI Fly app.

There was that Pixel 6 fingerprint reader issue that would start once battery is discharged. The issue already received a fix via a minor update. We also remember that Pixel 6 Pro flickering display problem.

And today, we’re learning some units are losing their signal. It’s not just happening in the United States but also in other markets like Canada. A Reddit thread has been dedicated for this issue. The problem is said to happen randomly.

It’s not clear how many phone owners have experienced the issue but a Google support forum page is now full with related complaints. Restarting the phone is said to have fixed the problem for some users.

Some Pixel 6 phone owners got their replacement units after contacting Google support. Some owners were also told to simply rest the network on their phones. There are a few who simply got a replacement SIM card.

The reason isn’t clear but it could be connected to the Exynos 5123b modem as per some sources. Definitely, there’s something wrong with the network connectivity. We’re crossing our fingers Google will be able to identify the problem and offer a fix.