Asus Transformer Prime ICS update failing on some tablets

January 17, 2012
6

Asus has worked commendably fast on bringing Ice Cream Sandwich to its flagship tablet, the Eee Pad Transformer Prime. Just two months after the open source code for Android 4.0 was available, an official update is ready for any who want to download it. But apparently not everyone is tasting the ice cream just yet: several XDA members report that their tablets are displaying a serial number error when applying the update, and keeping the software from installing.

Asus says that it has identified and replicated the serial number issue, and is working on a fix. Demonstrating remarkable customer communication, Asus' Technical Marketing Manager Gary Key responded to the thread directly, working with individuals and coordinating with the engineering department to develop a fix. While a permanent solution is forthcoming, Key recommends performing a factory data reset, then leaving the Transformer Prime connected to a WiFi network and waiting for the update alert to appear.

Unfortunately, the serial number issue isn't the only one to crop up. Some users are also reporting that after the update their screen locks up, essentially making the tablet unusable. Key advises that Asus is aware of this problem as well and is trying to replicate it, with a fix coming soon. These problems are unfortunately rather typical for OS updates, and at the moment seem to be isolated to a small number of users. The much-anticipated bootloader unlock should come sometime next month.

[via Cnet]


Recent Stories
  • Upirons

    I just got my ship notice from Expansys-USA and will have my 64GB Grey Prime tomorrow. I think I will wait until some of these issues are worked out before I go straight to ICS out of the box because after waiting 2 months, the last thing I want to do is brick it!

    • http://twitter.com/smartassphone John Blair

      Uhm… One problem with that approach. You can “Delay” the update twice, by using a provided button with several ranges of time (1 hour, 3 hours etc.) but form all that I have read on this, as well as my experience with the TF101, you are pretty much forced to accept the update on the 3rd go around. Fortunately, I took it the first time it was offered, and apart from spending time finding a lot of the new features in ICS, I have not had any issues. Another failure cropping up on some upgraded Primes is vertical banding, or some type of diagonal lines on the screen, Gary, and Asus are aware of this issue as well, but I have yet to see a resolution. Also the author is a bit misleading on the Serial number issue, and the advised solution (Data reset, wait for update) I heard that this worked for several people, but ALL of the forum thread I read show no success with this method, so it does not appear to be a solid workaround, at least for most.

      I agree Asus is trying very hard to respond quickly to these issues, and Gary Key working in the forum directly is refreshing to say the least. I hope it helps Asus recover SOME of the good will that was lost with all of the issues, and poor management of said issues since the (also problematic, late, poor supply management, missed commitments and retailer fails) release of this ultra-hyped, but out of the gate troubled tablet that has so much promise!

      • nobody

        No, that is wrong.  I have the TF101 and you can continue to ignore the update.

  • Poop

    poop… POOOP i say

  • jman

    My Tp froze after the last update before the ics update. It was made useless as the screen could not sence my touch. I sent it back from where i bought it. Hopefully the replacement wont act up with the ics update.

  • Pietro di Orleans

    I bought the Asus Transformer Prime a few days ago and thought that it was supposed to prompt me to install an update, but don’t get notice so I went to ASUS site and followed directions to download the update to a micro-SD which is best anyways. The build I have is build WW-epad.9.4.2.11 which struck me as odd since the box says that it has Honeycomb 3.2 and I thought these were Ice Cream Sandwich number. Anyways, I downloaded the WW version and then extracted it to the SD. The Prime detected the update file and asked if I wanted to install it. It prepared the update and after maybe 30 secs, it rebooted and then the green android was on his back with his hatch open and a big exclamation mark. Eventually a message appears in the status area at bottom right saying “System update failed” and nothing else to indicate the source of the problem. On the 1st try I thought it might have a problem with the NTFS format I used to prep the SD-micro, but got same results with FAT32. Is this just a variant of the other problems have reported on this forum ?