<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://androidcommunity.com/xmlrpc.php" />
    
		<!-- All in One SEO Pro 4.0.16 -->
		<title>OPPO overtakes Huawei, Xiaomi, and Apple in Chinese mobile market - Android Community</title>
		<meta name="description" content="We didn’t see this one coming but OPPO is now the number 1 mobile phone brand in China. It’s the first time it has happened—beating not just Huawei but also Xiaomi. The latest published report by Counterpoint Research’s Market Pulse Service. We’ve always known Huawei will be overtaken soon in its native country but not […]"/>
		<link rel="canonical" href="https://androidcommunity.com/oppo-overtakes-huawei-xiaomi-and-apple-in-chinese-mobile-market-20210308/" />
		<!-- All in One SEO Pro -->

<link rel="icon" type="image/png" href="https://androidcommunity.com/images/ac_favicon.png"><link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//cdn.androidcommunity.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Android Community &raquo; Feed" href="https://androidcommunity.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Android Community &raquo; Comments Feed" href="https://androidcommunity.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Android Community &raquo; OPPO overtakes Huawei, Xiaomi, and Apple in Chinese mobile market Comments Feed" href="https://androidcommunity.com/oppo-overtakes-huawei-xiaomi-and-apple-in-chinese-mobile-market-20210308/feed/" />
<link rel='stylesheet' id='wp-block-library-css'  href='https://cdn.androidcommunity.com/wp-includes/css/dist/block-library/style.min.css?ver=5.6.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link data-minify="1" rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://cdn.androidcommunity.com/wp-content/cache/min/1/wp-content/plugins/td-composer/td-multi-purpose/style-befce20364a22f643f5457c2f3693d3b.css' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Oswald%3A400%7COpen+Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700&#038;display=swap&#038;ver=10.3.9.1' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='td-theme-css'  href='https://cdn.androidcommunity.com/wp-content/cache/min/1/wp-content/themes/Newspaper/style-cf0203e11ffd2eb260c5aebae2e346b6.css' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link data-minify="1" rel='stylesheet' id='td-legacy-framework-front-style-css'  href='https://cdn.androidcommunity.com/wp-content/cache/min/1/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main-34db578c506fc19399f52308e186cb2a.css' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='td-standard-pack-framework-front-style-css'  href='https://cdn.androidcommunity.com/wp-content/cache/min/1/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main-e846cab5dfe3d2fa6590a70848834cef.css' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='jetpack_css-css'  href='https://cdn.androidcommunity.com/wp-content/cache/min/1/wp-content/plugins/jetpack/css/jetpack-31213a10836e29fafb224d4b73e972bc.css' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js?ver=2.2.4' id='jquery-js'></script>
<link rel="https://api.w.org/" href="https://androidcommunity.com/wp-json/" /><link rel="alternate" type="application/json" href="https://androidcommunity.com/wp-json/wp/v2/posts/420999" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://androidcommunity.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://androidcommunity.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://androidcommunity.com/?p=420999' />
<link rel="alternate" type="application/json+oembed" href="https://androidcommunity.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fandroidcommunity.com%2Foppo-overtakes-huawei-xiaomi-and-apple-in-chinese-mobile-market-20210308%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://androidcommunity.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fandroidcommunity.com%2Foppo-overtakes-huawei-xiaomi-and-apple-in-chinese-mobile-market-20210308%2F&#038;format=xml" />
<!-- Markup (JSON-LD) structured in schema.org ver.4.8.0 START -->
<script type="application/ld+json">
{
    "@context": "http://schema.org",
    "@type": "NewsArticle",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "https://androidcommunity.com/oppo-overtakes-huawei-xiaomi-and-apple-in-chinese-mobile-market-20210308/"
    },
    "headline": "OPPO overtakes Huawei, Xiaomi, and Apple in Chinese mobile market",
    "datePublished": "2021-03-08T01:12:42-0600",
    "dateModified": "2021-03-08T03:54:55-0600",
    "author": {
        "@type": "Person",
        "name": "Rei Padla"
    },
    "description": "We didn’t see this one coming but OPPO is now the number 1 mobile phone brand in China. It’s the first time it",
    "image": {
        "@type": "ImageObject",
        "url": "https://cdn.androidcommunity.com/wp-content/uploads/2021/03/OPPO-Reno-Series.jpg",
        "width": 1280,
        "height": 800
    },
    "publisher": {
        "@type": "Organization",
        "name": "Android Community",
        "logo": {
            "@type": "ImageObject",
            "url": "https://cdn.androidcommunity.com/images/ac_retina_transparent.png",
            "width": 600,
            "height": 101
        }
    }
}
</script>
<!-- Markup (JSON-LD) structured in schema.org END -->
<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
    			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/androidcommunity.com\/wp-admin\/","wpRestNonce":"3858a45752","wpRestUrl":"https:\/\/androidcommunity.com\/wp-json\/","permalinkStructure":"\/%postname%-%year%%monthnum%%day%\/"};
			</script>
						<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="amphtml" href="https://androidcommunity.com/oppo-overtakes-huawei-xiaomi-and-apple-in-chinese-mobile-market-20210308/amp/">
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="OPPO overtakes Huawei, Xiaomi, and Apple in Chinese mobile market" />
<meta property="og:url" content="https://androidcommunity.com/oppo-overtakes-huawei-xiaomi-and-apple-in-chinese-mobile-market-20210308/" />
<meta property="og:description" content="We didn’t see this one coming but OPPO is now the number 1 mobile phone brand in China. It’s the first time it has happened—beating not just Huawei but also Xiaomi. The latest published report by C…" />
<meta property="article:published_time" content="2021-03-08T07:12:42+00:00" />
<meta property="article:modified_time" content="2021-03-08T09:54:55+00:00" />
<meta property="og:site_name" content="Android Community" />
<meta property="og:image" content="https://cdn.androidcommunity.com/wp-content/uploads/2021/03/OPPO-Reno-Series.jpg" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="800" />
<meta property="og:image:alt" content="OPPO Reno Series" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@Androids" />
<meta name="twitter:site" content="@Androids" />
<meta name="twitter:text:title" content="OPPO overtakes Huawei, Xiaomi, and Apple in Chinese mobile market" />
<meta name="twitter:image" content="https://cdn.androidcommunity.com/wp-content/uploads/2021/03/OPPO-Reno-Series.jpg?w=640" />
<meta name="twitter:image:alt" content="OPPO Reno Series" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->

<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>

 <script type="text/javascript" id="nsgpt" data-channel="homepage" src="https://cdn.nsstatic.net/ns/androidcommunity.com.js" async="true"></script>
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-NBNMP6T');</script>
<!-- End Google Tag Manager -->
<!-- Button style compiled by theme -->

<style>
    .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                    color: #658c2e;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #658c2e;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #658c2e;
                }
                .tdm-btn-style1 {
					background-color: #658c2e;
				}
				.tdm-btn-style2:before {
				    border-color: #658c2e;
				}
				.tdm-btn-style2 {
				    color: #658c2e;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #658c2e;
                    -moz-box-shadow: 0 2px 16px #658c2e;
                    box-shadow: 0 2px 16px #658c2e;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #658c2e;
                    -moz-box-shadow: 0 4px 26px #658c2e;
                    box-shadow: 0 4px 26px #658c2e;
				}
</style>

	<style id="tdw-css-placeholder"></style></head>

<body class="post-template-default single single-post postid-420999 single-format-standard td-standard-pack oppo-overtakes-huawei-xiaomi-and-apple-in-chinese-mobile-market global-block-template-14 single_template_2 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" rel="nofollow" href="https://facebook.com/androidcommunity" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" rel="nofollow" href="https://androidcommunity.com/feed/" title="RSS">
                <i class="td-icon-font td-icon-rss"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" rel="nofollow" href="https://twitter.com/androids" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-container"><ul id="menu-main" class="td-mobile-main-menu"><li id="menu-item-287240" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-287240"><a href="https://androidcommunity.com/">Home</a></li>
<li id="menu-item-401245" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-401245"><a href="https://androidcommunity.com/topic/phones/">Phones</a></li>
<li id="menu-item-401247" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-401247"><a href="https://androidcommunity.com/topic/tablets/">Tablets</a></li>
<li id="menu-item-401696" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-401696"><a href="https://androidcommunity.com/topic/wearables/">Wearables</a></li>
<li id="menu-item-401252" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-401252"><a href="https://androidcommunity.com/topic/apps/">Apps</a></li>
<li id="menu-item-401253" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-401253"><a href="https://androidcommunity.com/topic/games/">Games</a></li>
<li id="menu-item-401251" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-401251"><a href="https://androidcommunity.com/section/reviews/">Reviews</a></li>
<li id="menu-item-246933" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-246933"><a href="https://androidcommunity.com/send-tips/">Tip Us</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text">
	                <a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
	                </div>
	                <div class="td-login-register-link">
	                
	                </div>
	                
	                <div class="td-login-info-text"><a class="privacy-policy-link" href="https://androidcommunity.com/privacy-policy/">Privacy Policy</a></div>

                </div>
            </div>

            
            
            
            
            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search">
		<form method="get" class="td-search-form" action="https://androidcommunity.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
	</div>
</div>

    <div id="td-outer-wrap" class="td-theme-wrap">
    
        
            <div class="tdc-header-wrap ">

            <!--
Header style 5
-->


<div class="td-header-wrap td-header-style-5 ">
    
    <div class="td-header-top-menu-full td-container-wrap ">
        <div class="td-container td-header-row td-header-top-menu">
            <!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <div class="td-login-wrap">
                        <a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
                        <div id="td-login-div" class="td-login-form-div td-display-block">
                            <div class="td-login-panel-title">Sign in</div>
                            <div class="td-login-panel-descr">Welcome! Log into your account</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
	                        <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
                            
                            
                            
                            <div class="td-login-info-text"><a class="privacy-policy-link" href="https://androidcommunity.com/privacy-policy/">Privacy Policy</a></div>
                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
                            <div class="td-login-panel-title">Password recovery</div>
                            <div class="td-login-panel-descr">Recover your password</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
                            <div class="td-login-info-text">A password will be e-mailed to you.</div>
                        </div>
                        
                        
                    </div>
                </div>
                        </div>
    </div>

    <div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap ">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-mobile" href="https://androidcommunity.com/">
			<img class="td-retina-data" data-retina="https://androidcommunity.com/images/ac_mobileretina.png" src="https://androidcommunity.com/images/ac_mobile.png" alt="Android Community" title="Android Community"/>
		</a>
			<a class="td-header-logo td-sticky-mobile" href="https://androidcommunity.com/">
			<img class="td-retina-data" data-retina="https://androidcommunity.com/images/aclogo_retina.png" src="https://androidcommunity.com/images/aclogo.png" alt="Android Community" title="Android Community"/>
			<span class="td-visual-hidden">Android Community</span>
		</a>
	    </div>
    <div class="menu-main-container"><ul id="menu-main-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-287240"><a href="https://androidcommunity.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag td-menu-item td-normal-menu menu-item-401245"><a href="https://androidcommunity.com/topic/phones/">Phones</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag td-menu-item td-normal-menu menu-item-401247"><a href="https://androidcommunity.com/topic/tablets/">Tablets</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag td-menu-item td-normal-menu menu-item-401696"><a href="https://androidcommunity.com/topic/wearables/">Wearables</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag td-menu-item td-normal-menu menu-item-401252"><a href="https://androidcommunity.com/topic/apps/">Apps</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag td-menu-item td-normal-menu menu-item-401253"><a href="https://androidcommunity.com/topic/games/">Games</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-401251"><a href="https://androidcommunity.com/section/reviews/">Reviews</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-246933"><a href="https://androidcommunity.com/send-tips/">Tip Us</a></li>
</ul></div></div>

<div class="td-header-menu-social">
        <span class="td-social-icon-wrap">
            <a target="_blank" rel="nofollow" href="https://facebook.com/androidcommunity" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" rel="nofollow" href="https://androidcommunity.com/feed/" title="RSS">
                <i class="td-icon-font td-icon-rss"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" rel="nofollow" href="https://twitter.com/androids" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div>
    <div class="header-search-wrap">
        <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>

        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://androidcommunity.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    </div>
            </div>
        </div>
    </div>

            <div class="td-header-header-full td-banner-wrap-full td-container-wrap ">
            <div class="td-container-header td-header-row td-header-header">
                <div class="td-header-sp-recs">
                    <div class="td-header-rec-wrap">
    
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-header tdi_1_ff4 td_block_template_14 ">

<style>
/* custom css */
.tdi_1_ff4.td-a-rec{
					text-align: center;
				}.tdi_1_ff4 .td-element-style{
					z-index: -1;
				}.tdi_1_ff4.td-a-rec-img{
				    text-align: left;
				}.tdi_1_ff4.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_1_ff4.td-a-rec-img {
				        text-align: center;
				    }
                }
</style><script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="4892688353"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="4892688353"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="4892688353"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="4892688353"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 


</div>                </div>
            </div>
        </div>
    
</div>
            </div>

            
<div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-2">
        <article id="post-420999" class="post-420999 post type-post status-publish format-standard has-post-thumbnail hentry category-archive tag-android tag-business tag-oppo tag-phones" >
            <div class="td-pb-row">
                <div class="td-pb-span12">
                    <div class="td-post-header">
                        <div class="td-crumb-container"></div>

                        
                        <header class="td-post-title">
                            <h1 class="entry-title">OPPO overtakes Huawei, Xiaomi, and Apple in Chinese mobile market</h1>

                            

                            <div class="td-module-meta-info">
                                <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://androidcommunity.com/author/reah/">Rei Padla</a><div class="td-author-line"> - </div> </div>                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-03-08T01:12:42-06:00" >March 8, 2021</time></span>                                                                <div class="td-post-comments"><a href="https://androidcommunity.com/oppo-overtakes-huawei-xiaomi-and-apple-in-chinese-mobile-market-20210308/#disqus_thread"><i class="td-icon-comments"></i>0</a></div>                            </div>

                        </header>
                    </div>
                </div>
            </div> <!-- /.td-pb-row -->

            <div class="td-pb-row">
                                            <div class="td-pb-span8 td-main-content" role="main">
                                <div class="td-ss-main-content">
                                    
        

        <div class="td-post-content tagdiv-type">
            <div class="td-post-featured-image"><img width="696" height="435" class="entry-thumb" src="https://cdn.androidcommunity.com/wp-content/uploads/2021/03/OPPO-Reno-Series-696x435.jpg" srcset="https://cdn.androidcommunity.com/wp-content/uploads/2021/03/OPPO-Reno-Series-696x435.jpg 696w, https://cdn.androidcommunity.com/wp-content/uploads/2021/03/OPPO-Reno-Series-768x480.jpg 768w, https://cdn.androidcommunity.com/wp-content/uploads/2021/03/OPPO-Reno-Series-1068x668.jpg 1068w, https://cdn.androidcommunity.com/wp-content/uploads/2021/03/OPPO-Reno-Series-672x420.jpg 672w, https://cdn.androidcommunity.com/wp-content/uploads/2021/03/OPPO-Reno-Series.jpg 1280w" sizes="(max-width: 696px) 100vw, 696px" alt="OPPO Reno Series" title="OPPO Reno Series"/></div>
            <p>We didn’t see this one coming but OPPO is now the number 1 mobile phone brand in China. It’s the first time it has happened—beating not just Huawei but also Xiaomi. The latest published report by Counterpoint Research’s Market Pulse Service. We’ve always known Huawei will be overtaken soon in its native country but not by OPPO but by Xiaomi. But you know, nothing is certain in life especially in the mobile business. We may not see Huawei back up yet but we’re more curious now about OPPO.</p>
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_inline tdi_2_997 td_block_template_14 ">

<style>
/* custom css */
.tdi_2_997.td-a-rec{
					text-align: center;
				}.tdi_2_997 .td-element-style{
					z-index: -1;
				}.tdi_2_997.td-a-rec-img{
				    text-align: left;
				}.tdi_2_997.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_2_997.td-a-rec-img {
				        text-align: center;
				    }
                }
</style><script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="2333568424"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="2333568424"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="2333568424"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="2333568424"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 


<p></p>
<p><span id="more-420999"></span></p>
<p>In January, China saw a shift in the mobile industry. OPPO is now on top, followed by Vivo. It was a close fight with 21% and 20% share, respectively. Each capturing 16% of the market were Huawei, Apple, and Xiaomi.</p>
<p>OPPO’s numbers actually grew month-on-month to 33%. Year-on-year, same month, there was a 25% improvement. This is impressive and the good news was made possible by the lower price point and a stronger product portfolio.</p>
<p>Counterpoint Research’s Senior Analyst <a href="https://www.counterpointresearch.com/oppo-becomes-number-1-smartphone-brand-china-first-time-ever/" target="_blank" rel="noopener">said</a>:<em> “OPPO has been successfully able to reposition its product lines in 2020. The rebranding of the Reno series and launching a more capable device at a lower price point than its predecessor helped OPPO capture the affordable premium segment. The strong momentum of the A series in the mid segment strengthened the product portfolio for OPPO and it was able to cater to the 5G demand in China across a wide price band. This was further helped by the decline of Huawei.”</em></p>
<p>Huawei’s number further went south, no thanks to HONOR becoming a separate band. It may even get worse as Huawei is having a hard time producing <a href="https://androidcommunity.com/topic/5g-phone/">5G phones</a> and other devices.</p>
<p>Online, Xiaomi is more popular. Offline, OPPO and Vivo sell more. Huawei has thousands of retail stores in China but the numbers are getting smaller than ever since the last quarter of 2020. We believe it will continue to do down in the coming months.</p>
<p>Now we’re curious if OPPO will be able to maintain its ranking. It’s possible because the company really knows branding and marketing. It offers phones with premium specs at more affordable prices.</p>
<p>More 5G phones are also offered by the company, particularly the OPPO Reno and OPPO A series. In the coming months, OPPO may also be available in more markets outside China like Western Europe. This month will greatly out OPPO on the global consumer map.</p>

 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_bottom tdi_3_644 td_block_template_14 ">

<style>
/* custom css */
.tdi_3_644.td-a-rec{
					text-align: center;
				}.tdi_3_644 .td-element-style{
					z-index: -1;
				}.tdi_3_644.td-a-rec-img{
				    text-align: left;
				}.tdi_3_644.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_3_644.td-a-rec-img {
				        text-align: center;
				    }
                }
</style><script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="2596892046"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="2596892046"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="2596892046"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="2596892046"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://androidcommunity.com/topic/android/">Android</a></li><li><a href="https://androidcommunity.com/topic/business/">Business</a></li><li><a href="https://androidcommunity.com/topic/oppo/">OPPO</a></li><li><a href="https://androidcommunity.com/topic/phones/">Phones</a></li></ul>            </div>

            <div class="td-post-sharing-bottom"><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-dark-bg td-ps-notext td-post-sharing-style14 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fandroidcommunity.com%2Foppo-overtakes-huawei-xiaomi-and-apple-in-chinese-mobile-market-20210308%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=OPPO+overtakes+Huawei%2C+Xiaomi%2C+and+Apple+in+Chinese+mobile+market&url=https%3A%2F%2Fandroidcommunity.com%2Foppo-overtakes-huawei-xiaomi-and-apple-in-chinese-mobile-market-20210308%2F&via=Android+Community">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://androidcommunity.com/oppo-overtakes-huawei-xiaomi-and-apple-in-chinese-mobile-market-20210308/&title=OPPO+overtakes+Huawei%2C+Xiaomi%2C+and+Apple+in+Chinese+mobile+market">
                                        <div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div>
                                        <div class="td-social-but-text">Linkedin</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://androidcommunity.com/oppo-overtakes-huawei-xiaomi-and-apple-in-chinese-mobile-market-20210308/&title=OPPO+overtakes+Huawei%2C+Xiaomi%2C+and+Apple+in+Chinese+mobile+market">
                                        <div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
                                        <div class="td-social-but-text">ReddIt</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>                        <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://androidcommunity.com/author/reah/">Rei Padla</a></span></div>	                </footer>

    
<div id="disqus_thread">
		</div>
                                </div>
                            </div>
                            <div class="td-pb-span4 td-main-sidebar" role="complementary">
                                <div class="td-ss-main-sidebar">
                                    <aside class="td_block_template_14 widget widget_text">			<div class="textwidget"><div style="text-align: center; padding: 10px 0px; background-color: #ddd;">
<!-- begin ad tag (tile=2) -->
<div data-ns="halfpage"></div>
<!-- end ad tag -->
</div></div>
		</aside><div class="td_block_wrap td_block_1 td_block_widget tdi_4_785 td-pb-border-top td_block_template_14 td-column-1"  data-td-block-uid="tdi_4_785" >
<style>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</style><script>var block_tdi_4_785 = new tdBlock();
block_tdi_4_785.id = "tdi_4_785";
block_tdi_4_785.atts = '{"custom_title":"Features","custom_url":"","block_template_id":"","header_text_color":"#","header_color":"#","border_color":"#","accent_text_color":"#","m4_tl":"","m4_el":"","m6_tl":"","limit":"3","offset":"","el_class":"","post_ids":"","category_id":"5380","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_4_785","block_type":"td_block_1","separator":"","show_modified_date":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m4f_title_font_header":"","m4f_title_font_title":"Article title","m4f_title_font_settings":"","m4f_title_font_family":"","m4f_title_font_size":"","m4f_title_font_line_height":"","m4f_title_font_style":"","m4f_title_font_weight":"","m4f_title_font_transform":"","m4f_title_font_spacing":"","m4f_title_":"","m4f_cat_font_title":"Article category tag","m4f_cat_font_settings":"","m4f_cat_font_family":"","m4f_cat_font_size":"","m4f_cat_font_line_height":"","m4f_cat_font_style":"","m4f_cat_font_weight":"","m4f_cat_font_transform":"","m4f_cat_font_spacing":"","m4f_cat_":"","m4f_meta_font_title":"Article meta info","m4f_meta_font_settings":"","m4f_meta_font_family":"","m4f_meta_font_size":"","m4f_meta_font_line_height":"","m4f_meta_font_style":"","m4f_meta_font_weight":"","m4f_meta_font_transform":"","m4f_meta_font_spacing":"","m4f_meta_":"","m4f_ex_font_title":"Article excerpt","m4f_ex_font_settings":"","m4f_ex_font_family":"","m4f_ex_font_size":"","m4f_ex_font_line_height":"","m4f_ex_font_style":"","m4f_ex_font_weight":"","m4f_ex_font_transform":"","m4f_ex_font_spacing":"","m4f_ex_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"tdi_4_785","tdc_css_class_style":"tdi_4_785_rand_style"}';
block_tdi_4_785.td_column_number = "1";
block_tdi_4_785.block_type = "td_block_1";
block_tdi_4_785.post_count = "3";
block_tdi_4_785.found_posts = "1260";
block_tdi_4_785.header_color = "#";
block_tdi_4_785.ajax_pagination_infinite_stop = "";
block_tdi_4_785.max_num_pages = "420";
tdBlocksArray.push(block_tdi_4_785);
</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span>Features</span></h4></div><div id=tdi_4_785 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_4 td_module_wrap td-animation-stack">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://androidcommunity.com/microsoft-surface-duo-prices-now-discounted-on-amazon-best-buy-20210210/" rel="bookmark" class="td-image-wrap " title="Microsoft Surface Duo prices now discounted on Amazon, Best Buy" ><img width="324" height="235" class="entry-thumb" src="https://cdn.androidcommunity.com/wp-content/uploads/2021/02/Microsoft-Surface-Duo-Discount-Amazon-Best-Buy-324x235.jpg"   alt="Microsoft Surface Duo Discount Amazon Best Buy" title="Microsoft Surface Duo prices now discounted on Amazon, Best Buy" /></a></div>                            </div>

            <h3 class="entry-title td-module-title"><a href="https://androidcommunity.com/microsoft-surface-duo-prices-now-discounted-on-amazon-best-buy-20210210/" rel="bookmark" title="Microsoft Surface Duo prices now discounted on Amazon, Best Buy">Microsoft Surface Duo prices now discounted on Amazon, Best Buy</a></h3>
            <div class="td-module-meta-info">
                <span class="td-post-author-name"><a href="https://androidcommunity.com/author/reah/">Rei Padla</a> <span>-</span> </span>                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-02-10T02:00:05-06:00" >February 10, 2021</time></span>                            </div>

            <div class="td-excerpt">
                If you’ve been wanting to purchase a Microsoft Surface Duo, you may want to grab one very soon as the device is about to...            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://androidcommunity.com/android-12-features-enhancements-leaked-before-launch-20210208/" rel="bookmark" class="td-image-wrap " title="Android 12 features, enhancements leaked before launch" ><img width="100" height="70" class="entry-thumb" src="https://cdn.androidcommunity.com/wp-content/uploads/2021/02/Android-12-Concept-Logo-100x70.jpg"  srcset="https://cdn.androidcommunity.com/wp-content/uploads/2021/02/Android-12-Concept-Logo-100x70.jpg 100w, https://cdn.androidcommunity.com/wp-content/uploads/2021/02/Android-12-Concept-Logo-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="Android 12 Concept Logo" title="Android 12 features, enhancements leaked before launch" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://androidcommunity.com/android-12-features-enhancements-leaked-before-launch-20210208/" rel="bookmark" title="Android 12 features, enhancements leaked before launch">Android 12 features, enhancements leaked before launch</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-02-08T23:15:01-06:00" >February 8, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://androidcommunity.com/xiaomi-mi-air-charge-technology-with-5w-remote-charging-launched-20210129/" rel="bookmark" class="td-image-wrap " title="Xiaomi Mi Air Charge Technology with 5W remote charging launched" ><img width="100" height="70" class="entry-thumb" src="https://cdn.androidcommunity.com/wp-content/uploads/2021/01/Xiaomi-Mi-Air-Charge-Technology-100x70.jpg"  srcset="https://cdn.androidcommunity.com/wp-content/uploads/2021/01/Xiaomi-Mi-Air-Charge-Technology-100x70.jpg 100w, https://cdn.androidcommunity.com/wp-content/uploads/2021/01/Xiaomi-Mi-Air-Charge-Technology-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="Xiaomi Mi Air Charge Technology" title="Xiaomi Mi Air Charge Technology with 5W remote charging launched" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://androidcommunity.com/xiaomi-mi-air-charge-technology-with-5w-remote-charging-launched-20210129/" rel="bookmark" title="Xiaomi Mi Air Charge Technology with 5W remote charging launched">Xiaomi Mi Air Charge Technology with 5W remote charging launched</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-01-29T03:00:37-06:00" >January 29, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block --><aside class="td_block_template_14 widget widget_text">			<div class="textwidget"><div style="text-align: center; background: #f2f2f2; padding: 1px;">
<!-- begin ad tag (tile=3) -->
<div data-ns="rectangle"></div>
<!-- end ad tag -->
</div>


</div>
		</aside><div class="td_block_wrap td_block_1 td_block_widget tdi_5_697 td-pb-border-top td_block_template_14 td-column-1"  data-td-block-uid="tdi_5_697" >
<style>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</style><script>var block_tdi_5_697 = new tdBlock();
block_tdi_5_697.id = "tdi_5_697";
block_tdi_5_697.atts = '{"custom_title":"Latest Stories","custom_url":"","block_template_id":"","header_text_color":"#","header_color":"#","border_color":"#","accent_text_color":"#","m4_tl":"","m4_el":"","m6_tl":"","limit":"5","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_5_697","block_type":"td_block_1","separator":"","show_modified_date":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m4f_title_font_header":"","m4f_title_font_title":"Article title","m4f_title_font_settings":"","m4f_title_font_family":"","m4f_title_font_size":"","m4f_title_font_line_height":"","m4f_title_font_style":"","m4f_title_font_weight":"","m4f_title_font_transform":"","m4f_title_font_spacing":"","m4f_title_":"","m4f_cat_font_title":"Article category tag","m4f_cat_font_settings":"","m4f_cat_font_family":"","m4f_cat_font_size":"","m4f_cat_font_line_height":"","m4f_cat_font_style":"","m4f_cat_font_weight":"","m4f_cat_font_transform":"","m4f_cat_font_spacing":"","m4f_cat_":"","m4f_meta_font_title":"Article meta info","m4f_meta_font_settings":"","m4f_meta_font_family":"","m4f_meta_font_size":"","m4f_meta_font_line_height":"","m4f_meta_font_style":"","m4f_meta_font_weight":"","m4f_meta_font_transform":"","m4f_meta_font_spacing":"","m4f_meta_":"","m4f_ex_font_title":"Article excerpt","m4f_ex_font_settings":"","m4f_ex_font_family":"","m4f_ex_font_size":"","m4f_ex_font_line_height":"","m4f_ex_font_style":"","m4f_ex_font_weight":"","m4f_ex_font_transform":"","m4f_ex_font_spacing":"","m4f_ex_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"tdi_5_697","tdc_css_class_style":"tdi_5_697_rand_style"}';
block_tdi_5_697.td_column_number = "1";
block_tdi_5_697.block_type = "td_block_1";
block_tdi_5_697.post_count = "5";
block_tdi_5_697.found_posts = "54141";
block_tdi_5_697.header_color = "#";
block_tdi_5_697.ajax_pagination_infinite_stop = "";
block_tdi_5_697.max_num_pages = "10829";
tdBlocksArray.push(block_tdi_5_697);
</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span>Latest Stories</span></h4></div><div id=tdi_5_697 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_4 td_module_wrap td-animation-stack">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://androidcommunity.com/twitter-testing-out-undo-send-for-paying-subscribers-20210308/" rel="bookmark" class="td-image-wrap " title="Twitter testing out &#8220;undo send&#8221; for paying subscribers" ><img width="324" height="235" class="entry-thumb" src="https://cdn.androidcommunity.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-08-at-3.53.36-PM-324x235.jpg"   alt="" title="Twitter testing out &#8220;undo send&#8221; for paying subscribers" /></a></div>                            </div>

            <h3 class="entry-title td-module-title"><a href="https://androidcommunity.com/twitter-testing-out-undo-send-for-paying-subscribers-20210308/" rel="bookmark" title="Twitter testing out &#8220;undo send&#8221; for paying subscribers">Twitter testing out &#8220;undo send&#8221; for paying subscribers</a></h3>
            <div class="td-module-meta-info">
                <span class="td-post-author-name"><a href="https://androidcommunity.com/author/ida/">Ida Torres</a> <span>-</span> </span>                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-03-08T03:00:15-06:00" >March 8, 2021</time></span>                            </div>

            <div class="td-excerpt">
                Twitter users, we have to truly accept that we will probably never get that edit tweet button that we’ve been asking for. The social...            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://androidcommunity.com/marshall-mode-ii-is-the-brands-first-truly-wireless-earbuds-20210308/" rel="bookmark" class="td-image-wrap " title="Marshall Mode II is the brand&#8217;s first truly wireless earbuds" ><img width="100" height="70" class="entry-thumb" src="https://cdn.androidcommunity.com/wp-content/uploads/2021/03/marshall_mode-II_insert-100x70.jpeg"  srcset="https://cdn.androidcommunity.com/wp-content/uploads/2021/03/marshall_mode-II_insert-100x70.jpeg 100w, https://cdn.androidcommunity.com/wp-content/uploads/2021/03/marshall_mode-II_insert-218x150.jpeg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Marshall Mode II is the brand&#8217;s first truly wireless earbuds" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://androidcommunity.com/marshall-mode-ii-is-the-brands-first-truly-wireless-earbuds-20210308/" rel="bookmark" title="Marshall Mode II is the brand&#8217;s first truly wireless earbuds">Marshall Mode II is the brand&#8217;s first truly wireless earbuds</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-03-08T02:00:54-06:00" >March 8, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://androidcommunity.com/oppo-overtakes-huawei-xiaomi-and-apple-in-chinese-mobile-market-20210308/" rel="bookmark" class="td-image-wrap " title="OPPO overtakes Huawei, Xiaomi, and Apple in Chinese mobile market" ><img width="100" height="70" class="entry-thumb" src="https://cdn.androidcommunity.com/wp-content/uploads/2021/03/OPPO-Reno-Series-100x70.jpg"  srcset="https://cdn.androidcommunity.com/wp-content/uploads/2021/03/OPPO-Reno-Series-100x70.jpg 100w, https://cdn.androidcommunity.com/wp-content/uploads/2021/03/OPPO-Reno-Series-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="OPPO Reno Series" title="OPPO overtakes Huawei, Xiaomi, and Apple in Chinese mobile market" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://androidcommunity.com/oppo-overtakes-huawei-xiaomi-and-apple-in-chinese-mobile-market-20210308/" rel="bookmark" title="OPPO overtakes Huawei, Xiaomi, and Apple in Chinese mobile market">OPPO overtakes Huawei, Xiaomi, and Apple in Chinese mobile market</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-03-08T01:12:42-06:00" >March 8, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://androidcommunity.com/fitbit-ace-3-rolling-out-for-the-kids-leaked-info-available-20210307/" rel="bookmark" class="td-image-wrap " title="Fitbit Ace 3 rolling out for the kids, leaked info available" ><img width="100" height="70" class="entry-thumb" src="https://cdn.androidcommunity.com/wp-content/uploads/2021/03/Fitbit-Ace-3-100x70.jpg"  srcset="https://cdn.androidcommunity.com/wp-content/uploads/2021/03/Fitbit-Ace-3-100x70.jpg 100w, https://cdn.androidcommunity.com/wp-content/uploads/2021/03/Fitbit-Ace-3-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="Fitbit Ace 3" title="Fitbit Ace 3 rolling out for the kids, leaked info available" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://androidcommunity.com/fitbit-ace-3-rolling-out-for-the-kids-leaked-info-available-20210307/" rel="bookmark" title="Fitbit Ace 3 rolling out for the kids, leaked info available">Fitbit Ace 3 rolling out for the kids, leaked info available</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-03-07T23:16:11-06:00" >March 7, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://androidcommunity.com/more-samsung-galaxy-a52-galaxy-a72-images-and-details-surfacing-20210307/" rel="bookmark" class="td-image-wrap " title="More Samsung Galaxy A52, Galaxy A72 images and details surfacing" ><img width="100" height="70" class="entry-thumb" src="https://cdn.androidcommunity.com/wp-content/uploads/2021/03/Samsung-Galaxy-A52-5G-Hands-on-Images-100x70.jpg"  srcset="https://cdn.androidcommunity.com/wp-content/uploads/2021/03/Samsung-Galaxy-A52-5G-Hands-on-Images-100x70.jpg 100w, https://cdn.androidcommunity.com/wp-content/uploads/2021/03/Samsung-Galaxy-A52-5G-Hands-on-Images-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="Samsung Galaxy A52 5G Hands-on Images" title="More Samsung Galaxy A52, Galaxy A72 images and details surfacing" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://androidcommunity.com/more-samsung-galaxy-a52-galaxy-a72-images-and-details-surfacing-20210307/" rel="bookmark" title="More Samsung Galaxy A52, Galaxy A72 images and details surfacing">More Samsung Galaxy A52, Galaxy A72 images and details surfacing</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-03-07T21:29:49-06:00" >March 7, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->                                </div>
                            </div>
                                    </div> <!-- /.td-pb-row -->
        </article> <!-- /.post -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->

	
	
            <div class="tdc-footer-wrap ">

                <!-- Footer -->
				<div class="td-footer-wrapper td-footer-container td-container-wrap ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
                		    </div>
	    </div>

        <div class="td-pb-row">
            <div class="td-pb-span12">
                <aside class="widget_text td_block_template_14 widget widget_custom_html"><div class="textwidget custom-html-widget">Copyright © Android Community.<br />Part of GiXiO K.K. Network<br /><br /><br />

<a href="https://androidcommunity.com/privacy-policy/">Privacy Policy</a> / <a href="https://androidcommunity.com/terms-of-use/">Terms of Use</a> / 
<a href="https://androidcommunity.com/about/">About</a> / <a href="https://androidcommunity.com/advertise/">Advertise</a> / <a href="https://androidcommunity.com/send-tips/">Tip Us</a> / <a href="https://androidcommunity.com/contact/">Contact</a> / <a href="https://androidcommunity.com/archives/">Archives</a></div></aside>            </div>
        </div>
    </div>
</div>
                <!-- Sub Footer -->
				            </div><!--close td-footer-wrap-->
			
</div><!--close td-outer-wrap-->




    <!--

        Theme: Newspaper by tagDiv.com 2020
        Version: 10.3.9.1 (rara)
        Deploy mode: deploy
        
        uid: 6045f4749f23d
    -->

    
<!-- Custom css from theme panel -->
<style type="text/css" media="screen">
/* custom css theme panel */
.grecaptcha-badge{
	visibility: collapse !important;  
}

.td_block_wrap .td-load-more-wrap {
    margin-top: 50px;
}

.td_ajax_load_more {
    display: inline-block;
    font-family: 'Open Sans', arial, sans-serif;
    font-size: 12px;
    line-height: 1;
    padding: 10px 10px;
    border: 1px solid #C9C9C9;
    text-align: center;
    vertical-align: middle;
    background-color: #578c0c;
}

.td-load-more-wrap a {
    color: #fff;
    text-transform: uppercase;
}

.td-header-style-5 .td-header-top-menu-full {
    background-color: #588c0b;
}

.h1-bottom-liner {border-bottom:1px solid #ddd; padding-bottom: 8px;}

.td-header-style-5 .td-header-sp-recs, .td-header-style-6 .td-header-sp-recs, .td-header-style-7 .td-header-sp-recs, .td-header-style-8 .td-header-sp-recs, .td-header-style-9 .td-header-sp-recs, .td-header-style-10 .td-header-sp-recs, .td-header-style-11 .td-header-sp-recs, .td-header-style-12 .td-header-sp-recs {
    margin: 8px auto 8px auto !important;
}

.td-crumb-container {
    min-height: 2px;
    margin-bottom: 3px;
}

@media (max-width: 767px) {
.td-crumb-container {
    padding-top: 2px;
}
    }



/* custom responsive css from theme panel (Advanced CSS) */
@media (min-width: 1141px) {
    .td-banner-wrap-full, .td-header-menu-wrap-full {
    background-color: #f9f9f9;
    padding-bottom: 0px; }
 .td-post-template-3 .td-post-header-holder {
    margin-top: 20px;
}   

.banner-top {padding-bottom: 10px;}
    
}


/* custom responsive css from theme panel (Advanced CSS) */
@media (min-width: 1019px) and (max-width: 1140px) {
.td-banner-wrap-full, .td-header-menu-wrap-full {
    background-color: #f9f9f9;
    padding-bottom: 0px; }
 .td-post-template-3 .td-post-header-holder {
    margin-top: 20px;
}   

.banner-top {padding-bottom: 10px;}
    
}


/* custom responsive css from theme panel (Advanced CSS) */
@media (min-width: 768px) and (max-width: 1018px) {
.td-banner-wrap-full, .td-header-menu-wrap-full {
    background-color: #f9f9f9;
    padding-bottom: 0px; }
 .td-post-template-3 .td-post-header-holder {
    margin-top: 20px;
}   

.banner-top {padding-bottom: 10px;}
    
}
</style>

<script type='text/javascript' id='dcl_comments-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"androidcom"};
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.21"},"disqusIdentifier":"420999 https:\/\/androidcommunity.com\/?p=420999","disqusShortname":"androidcom","disqusTitle":"OPPO overtakes Huawei, Xiaomi, and Apple in Chinese mobile market","disqusUrl":"https:\/\/androidcommunity.com\/oppo-overtakes-huawei-xiaomi-and-apple-in-chinese-mobile-market-20210308\/","postId":"420999"};
var dclCustomVars = {"dcl_progress_text":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript' src='https://cdn.androidcommunity.com/wp-content/plugins/disqus-conditional-load/assets/js/public/embed-count-scroll.min.js?ver=11.0.5' id='dcl_comments-js' defer></script>
<script type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(.+\/)?feed\/?.+\/?|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/|\/wp-login.php","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/androidcommunity.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type='text/javascript' src='https://cdn.androidcommunity.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.3.9.1' id='td-site-min-js'></script>
<script type='text/javascript' src='https://cdn.androidcommunity.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/intersectionobserver-polyfill.min.js?ver=1.1.2' id='jetpack-lazy-images-polyfill-intersectionobserver-js' defer></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' src='https://cdn.androidcommunity.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js?ver=1.1.2' id='jetpack-lazy-images-js' defer></script>
<script type='text/javascript' src='https://cdn.androidcommunity.com/wp-includes/js/wp-embed.min.js?ver=5.6.2' id='wp-embed-js' defer></script>
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NBNMP6T"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
<!-- JS generated by theme -->

<script>
    
</script>


</body>
</html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1615197300 -->