<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>ASUS ROG Phone II Ultimate Edition, VivoWatch SP debut at IFA 2019 - Android Community</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://androidcommunity.com/xmlrpc.php" />
    <meta property="og:image" content="https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-ROG-Phone-II-Europe.jpg" /><link rel="icon" type="image/png" href="https://static.androidcommunity.com/images/ac_favicon.png">
<!-- All in One SEO Pack 3.2.5 by Michael Torbert of Semper Fi Web Design[208,301] -->
<meta name="description"  content="The Asus ROG Phone 2 has been highly anticipated ever since we first heard it would offer a 120Hz display experience. The device is also said to take advantage" />

<link rel="canonical" href="https://androidcommunity.com/asus-rog-phone-ii-ultimate-edition-vivowatch-sp-debut-at-ifa-2019-20190904/" />
<!-- All in One SEO Pack -->
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//static.androidcommunity.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Android Community &raquo; Feed" href="https://androidcommunity.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Android Community &raquo; Comments Feed" href="https://androidcommunity.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Android Community &raquo; ASUS ROG Phone II Ultimate Edition, VivoWatch SP debut at IFA 2019 Comments Feed" href="https://androidcommunity.com/asus-rog-phone-ii-ultimate-edition-vivowatch-sp-debut-at-ifa-2019-20190904/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/androidcommunity.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.2"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://androidcommunity.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.2' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Work+Sans%3A400%7COpen+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=8.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='main-style-css'  href='https://static.androidcommunity.com/css/ac-style.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://androidcommunity.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.6' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js?ver=2.2.4'></script>
<link rel='https://api.w.org/' href='https://androidcommunity.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://androidcommunity.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://androidcommunity.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Nest Hub Max will finally come out September 9' href='https://androidcommunity.com/nest-hub-max-will-finally-come-out-september-9-20190904/' />
<link rel='shortlink' href='https://androidcommunity.com/?p=390201' />
<link rel="alternate" type="application/json+oembed" href="https://androidcommunity.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fandroidcommunity.com%2Fasus-rog-phone-ii-ultimate-edition-vivowatch-sp-debut-at-ifa-2019-20190904%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://androidcommunity.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fandroidcommunity.com%2Fasus-rog-phone-ii-ultimate-edition-vivowatch-sp-debut-at-ifa-2019-20190904%2F&#038;format=xml" />
<!-- Markup (JSON-LD) structured in schema.org ver.4.6.5 START -->
<script type="application/ld+json">
{
    "@context": "http://schema.org",
    "@type": "NewsArticle",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "https://androidcommunity.com/asus-rog-phone-ii-ultimate-edition-vivowatch-sp-debut-at-ifa-2019-20190904/"
    },
    "headline": "ASUS ROG Phone II Ultimate Edition, VivoWatch SP debut at IFA 2019",
    "datePublished": "2019-09-04T20:40:33-0500",
    "dateModified": "2019-09-04T20:38:12-0500",
    "author": {
        "@type": "Person",
        "name": "Rei Padla"
    },
    "description": "The Asus ROG Phone 2 has been highly anticipated ever since we first heard it would offer a 120Hz display expe",
    "image": {
        "@type": "ImageObject",
        "url": "https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-ROG-Phone-II-Europe.jpg",
        "width": 1280,
        "height": 800
    },
    "publisher": {
        "@type": "Organization",
        "name": "Android Community",
        "logo": {
            "@type": "ImageObject",
            "url": "https://androidcommunity.com/wp-content/uploads/2019/04/ac_retina_transparent.png",
            "width": 600,
            "height": 101
        }
    }
}
</script>
<!-- Markup (JSON-LD) structured in schema.org END -->
<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <link rel="amphtml" href="https://androidcommunity.com/asus-rog-phone-ii-ultimate-edition-vivowatch-sp-debut-at-ifa-2019-20190904/amp/">
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="ASUS ROG Phone II Ultimate Edition, VivoWatch SP debut at IFA 2019" />
<meta property="og:url" content="https://androidcommunity.com/asus-rog-phone-ii-ultimate-edition-vivowatch-sp-debut-at-ifa-2019-20190904/" />
<meta property="og:description" content="The Asus ROG Phone 2 has been highly anticipated ever since we first heard it would offer a 120Hz display experience. The device is also said to take advantage of the latest Snapdragon 855 Plus chi…" />
<meta property="article:published_time" content="2019-09-05T01:40:33+00:00" />
<meta property="article:modified_time" content="2019-09-05T01:38:12+00:00" />
<meta property="og:site_name" content="Android Community" />
<meta property="og:image" content="https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-ROG-Phone-II-Europe.jpg" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="800" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@Androids" />
<meta name="twitter:site" content="@Androids" />
<meta name="twitter:text:title" content="ASUS ROG Phone II Ultimate Edition, VivoWatch SP debut at IFA 2019" />
<meta name="twitter:image" content="https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-ROG-Phone-II-Europe.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->

<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

	        if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

	        if ( navigator.userAgent.indexOf("Edge") > -1 ) {
                htmlTag.className += ' ieEdge';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="https:\/\/androidcommunity.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=8.7.2";
var td_get_template_directory_uri="https:\/\/androidcommunity.com\/wp-content\/themes\/ac87";
var tds_snap_menu="";
var tds_logo_on_sticky="";
var tds_header_style="5";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#658c2e";
var tds_smart_sidebar="";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

         <script type="text/javascript" id="nsgpt" data-channel="homepage" src="https://cdn.nsstatic.net/ns/androidcommunity.com.js" async="true"></script>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-645197-4"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-645197-4');
</script>
<link rel='stylesheet' id='custom-css'  href='https://static.androidcommunity.com/css/customstyle.min.css' type='text/css' media='all' />
</head>

<body class="post-template-default single single-post postid-390201 single-format-standard asus-rog-phone-ii-ultimate-edition-vivowatch-sp-debut-at-ifa-2019 global-block-template-1 single_template_2 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-container"><ul id="menu-main" class="td-mobile-main-menu"><li id="menu-item-287240" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-287240"><a href="https://androidcommunity.com/">Home</a></li>
<li id="menu-item-246925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-246925"><a href="https://androidcommunity.com/tag/smartphone/">Phones</a></li>
<li id="menu-item-246926" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-246926"><a href="https://androidcommunity.com/tag/tablet/">Tablets</a></li>
<li id="menu-item-246928" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-246928"><a href="https://androidcommunity.com/tag/app/">Apps</a></li>
<li id="menu-item-246933" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-246933"><a href="https://androidcommunity.com/send-tips/">Tip Us</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://androidcommunity.com/search-results/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input type="hidden" name="cx" value="009851139337901005932:mt7aa3eyyzm" />
    <input type="hidden" name="cof" value="FORID:11" />
    <input type="hidden" name="ie" value="UTF-8" />
	<input type="hidden" name="sa" id="sa" />       
				<input id="td-header-search-mob" type="text" value="" name="q" id="q" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>

    
    
    <div id="td-outer-wrap" class="td-theme-wrap">
    
        <!--
Header style 5
-->


<div class="td-header-wrap td-header-style-5 ">
    
    <div class="td-header-top-menu-full td-container-wrap ">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	</div>
        <div class="td-header-sp-top-widget">
    
    
            </div>    </div>

<!-- LOGIN MODAL -->
        </div>
    </div>

    <div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap ">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-disable" href="https://androidcommunity.com/">
			<img class="td-retina-data" data-retina="https://static.androidcommunity.com/images/ac_mobileretina.png" src="https://static.androidcommunity.com/images/ac_mobile.png" alt="Android Community" title="Android Community"/>
		</a>
			<a class="td-header-logo td-sticky-disable" href="https://androidcommunity.com/">
			<img class="td-retina-data" data-retina="https://static.androidcommunity.com/images/aclogo_retina.png" src="https://static.androidcommunity.com/images/aclogo.png" alt="Android Community" title="Android Community"/>
			<span class="td-visual-hidden">Android Community</span>
		</a>
	    </div>
    <div class="menu-main-container"><ul id="menu-main-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-287240"><a href="https://androidcommunity.com/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-246925"><a href="https://androidcommunity.com/tag/smartphone/">Phones</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-246926"><a href="https://androidcommunity.com/tag/tablet/">Tablets</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-246928"><a href="https://androidcommunity.com/tag/app/">Apps</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-246933"><a href="https://androidcommunity.com/send-tips/">Tip Us</a></li>
</ul></div></div>


    <div class="header-search-wrap">
        <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>

        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://androidcommunity.com/search-results/"">
                <div role="search" class="td-head-form-search-wrap">
<input type="hidden" name="cx" value="009851139337901005932:mt7aa3eyyzm" />
    <input type="hidden" name="cof" value="FORID:11" />
    <input type="hidden" name="ie" value="UTF-8" />
	<input type="hidden" name="sa" id="sa" />       
					<input id="td-header-search" type="text" value="" name="q" id="q" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    </div>
            </div>
        </div>
    </div>

    
</div><div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-2">
        <article id="post-390201" class="post-390201 post type-post status-publish format-standard has-post-thumbnail hentry category-archive tag-android tag-asus tag-asus-rog-phone-2" itemscope itemtype="https://schema.org/Article">
            <div class="td-pb-row">
                <div class="td-pb-span12">
                    <div class="td-post-header">
                        <div class="td-crumb-container"></div>

                        
                        <header class="td-post-title">
                            <h1 class="entry-title">ASUS ROG Phone II Ultimate Edition, VivoWatch SP debut at IFA 2019</h1>

                            

                            <div class="td-module-meta-info">
                                <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://androidcommunity.com/author/reah/">Rei Padla</a><div class="td-author-line"> - </div> </div>                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-09-04T20:40:33+00:00" >September 4, 2019</time></span>                                                                <div class="td-post-comments"><a href="https://androidcommunity.com/asus-rog-phone-ii-ultimate-edition-vivowatch-sp-debut-at-ifa-2019-20190904/#respond"><i class="td-icon-comments"></i>0</a></div>                            </div>

                        </header>
                    </div>
                </div>
            </div> <!-- /.td-pb-row -->

            <div class="td-pb-row">
                                            <div class="td-pb-span8 td-main-content" role="main">
                                <div class="td-ss-main-content">
                                    
        


        <div class="td-post-content">
            <div class="td-post-featured-image"><img width="696" height="435" class="entry-thumb" src="https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-ROG-Phone-II-Europe-696x435.jpg" srcset="https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-ROG-Phone-II-Europe-696x435.jpg 696w, https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-ROG-Phone-II-Europe-768x480.jpg 768w, https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-ROG-Phone-II-Europe-1068x668.jpg 1068w, https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-ROG-Phone-II-Europe-672x420.jpg 672w, https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-ROG-Phone-II-Europe.jpg 1280w" sizes="(max-width: 696px) 100vw, 696px" alt="" title="ASUS ROG Phone II Europe"/></div>
            
            <p>The Asus ROG Phone 2 has been highly anticipated ever since we first heard it would offer a 120Hz display experience. The device is also said to take advantage of the latest Snapdragon 855 Plus chipset and may run on up to 12GB of RAM. It sounded the new ASUS gaming phone will be very powerful. And true enough, the new-gen ASUS ROG Phone 2 II is more powerful than ever. If the original version was described as an overkill then this one is way worse but in a great way.</p></p>
<p>                 <div class="adsense_responsive_box" style="margin: 0 auto; text-align: center; padding: 1px 1px 1px 1px;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Above The Fold - High Viewability Within Content -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-8065766046515397"
     data-ad-slot="5135832846"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div><p>

        </p></p>
<p><!--more--></p></p>
<p>The new <strong>ASUS ROG Phone 2 Ultimate Edition</strong> is the more high-end version. It&#8217;s ultra-powerful with 1TB UFS 3.0 ROM, faster Cat 20 4G LTE download speed (up to 2Gbps), Snapdragon 855 Plus processor, 2.96GHz CPU, and a 6000mAh battery with 30W ROG HyperCharge tech. As we mentioned earlier, this gaming phone comes with a 120Hz/1ms AMOLED display and 49ms touch latency for an ultimate gaming experience. To add to the experience, there is the Dual Surrounding Vibration technology, front-facing stereo speakers, and AirTrigger II technology.</p></p>
<p>In the camera department, we only know there is a 48MP camera ready to take premium quality photos. Price is set at around €1,199 ($1,323). The regular ASUS ROG Phone 2 will cost €899 ($992) when it&#8217;s released this month. The higher-end variant will be out in October.</p>                 
                 
                  <div class="adsense_responsive_box" style="margin: 0 auto; text-align: center; padding: 1px 1px 1px 1px;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Above The Fold - High Viewability Within Content -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-8065766046515397"
     data-ad-slot="5135832846"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div><p>
                 
                 
                 
        </p>
<p><img class="alignnone size-full wp-image-390202" src="https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-VivoWatch-SP-Specs.jpg" alt="" width="800" height="800" srcset="https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-VivoWatch-SP-Specs.jpg 800w, https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-VivoWatch-SP-Specs-200x200.jpg 200w, https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-VivoWatch-SP-Specs-768x768.jpg 768w, https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-VivoWatch-SP-Specs-696x696.jpg 696w, https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-VivoWatch-SP-Specs-420x420.jpg 420w" sizes="(max-width: 800px) 100vw, 800px" /></p></p>
<p><a href="https://press.asus.com/PressReleases/p/ASUS-Announces-Digital-Solutions-for-Content-Creators-Business-Professionals-Health-and-Fitness-Enthusiasts-and-Gamers-at-IFA-2019" target="_blank" rel="noopener noreferrer">ASUS</a> also proudly announced the <strong>ASUS VivoWatch SP</strong>. The smartwatch features health and fitness tracking, insights, exercise goals, ECG and PPG sensors, and ASUS HealthAI technology. It&#8217;s ideal for those who want to seriously monitor and track their health and lifestyle. The usual health sensors are there: pulse O2 level, heart rate, blood pressure, stress level, and autonomic nerve activity index (ANS).</p></p>
<div id='gallery-1' class='gallery galleryid-390201 gallery-columns-3 gallery-size-thumbnail'><figure class='gallery-item'>
			<div class='gallery-icon landscape'>
				<a href='https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-ROG-Phone-II-Ultimate-Edition-1.jpg'><img width="200" height="200" src="https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-ROG-Phone-II-Ultimate-Edition-1-200x200.jpg" class="attachment-thumbnail size-thumbnail" alt="" /></a>
			</div></figure><figure class='gallery-item'>
			<div class='gallery-icon landscape'>
				<a href='https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-VivoWatch-SP-IFA-2019.jpg'><img width="200" height="200" src="https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-VivoWatch-SP-IFA-2019-200x200.jpg" class="attachment-thumbnail size-thumbnail" alt="" /></a>
			</div></figure><figure class='gallery-item'>
			<div class='gallery-icon landscape'>
				<a href='https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-VivoWatch-SP-Specs.jpg'><img width="200" height="200" src="https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-VivoWatch-SP-Specs-200x200.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-VivoWatch-SP-Specs-200x200.jpg 200w, https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-VivoWatch-SP-Specs.jpg 800w, https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-VivoWatch-SP-Specs-768x768.jpg 768w, https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-VivoWatch-SP-Specs-696x696.jpg 696w, https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-VivoWatch-SP-Specs-420x420.jpg 420w" sizes="(max-width: 200px) 100vw, 200px" /></a>
			</div></figure>
		</div>

<p>The <strong>ASUS VivoWatch SP</strong> comes with a built-in GPS sensor for tracking outdoor workouts. The phone connects with the ASUS HealthConnect mobile app so you can track your stats, maps, speed, duration, and distance. Pace coaching is also very helpful as it can monitor the user&#8217;s speed.</p></p>
<p>Other features include a built-in altimeter and a pulse O2 monitor. The smartwatch is swim-proof (up to 50 meters) while battery can last up to 14 days on normal usage.</p></p>
<div class="related-posts">
<div id="related-posts-MRP_all" class="related-posts-type">
<h2>Story Timeline</h2>
<ul class="st-related-posts">
<li><a href="https://androidcommunity.com/asus-rog-phone-2-may-use-the-latest-snapdragon-855-plus-chipset-20190716/">ASUS ROG Phone 2 may use the latest Snapdragon 855 Plus chipset</a></li>
<li><a href="https://androidcommunity.com/asus-rog-phone-will-run-up-to-12gb-of-ram-on-the-latest-sd-855-20190717/">ASUS ROG Phone will run up to 12GB of RAM on the latest SD 855+</a></li>
<li><a href="https://androidcommunity.com/asus-rog-phone-ii-will-be-really-powerful-20190723/">ASUS ROG Phone II will be really powerful</a></li>
</ul></div>
</div>
</p></p>

 
        </div>

<div style="margin: 0 auto; text-align: center; padding: 2px 1px 10px 1px;"><script type="text/javascript"><!--
google_ad_client = "ca-pub-8065766046515397";
/* AC Under Post 336x280 */
google_ad_slot = "2596892046";
google_ad_width = 336;
google_ad_height = 280;
//-->
</script>
<script type="text/javascript"
src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script></div>

        <footer>
                        
            <div class="td-post-source-tags">
                                <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://androidcommunity.com/tag/android/">Android</a></li><li><a href="https://androidcommunity.com/tag/asus/">Asus</a></li><li><a href="https://androidcommunity.com/tag/asus-rog-phone-2/">Asus ROG Phone 2</a></li></ul>            </div>

            <div class="td-post-sharing-bottom"><div id="td_uid_1_5d707c1b40cb6" class="td-post-sharing td-ps-dark-bg td-ps-notext td-post-sharing-style14 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fandroidcommunity.com%2Fasus-rog-phone-ii-ultimate-edition-vivowatch-sp-debut-at-ifa-2019-20190904%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=ASUS+ROG+Phone+II+Ultimate+Edition%2C+VivoWatch+SP+debut+at+IFA+2019&url=https%3A%2F%2Fandroidcommunity.com%2Fasus-rog-phone-ii-ultimate-edition-vivowatch-sp-debut-at-ifa-2019-20190904%2F&via=Android+Community">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-googleplus" href="https://plus.google.com/share?url=https://androidcommunity.com/asus-rog-phone-ii-ultimate-edition-vivowatch-sp-debut-at-ifa-2019-20190904/">
                                        <div class="td-social-but-icon"><i class="td-icon-googleplus"></i></div>
                                        <div class="td-social-but-text">Google+</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://androidcommunity.com/asus-rog-phone-ii-ultimate-edition-vivowatch-sp-debut-at-ifa-2019-20190904/&title=ASUS ROG Phone II Ultimate Edition, VivoWatch SP debut at IFA 2019">
                                        <div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div>
                                        <div class="td-social-but-text">Linkedin</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://androidcommunity.com/asus-rog-phone-ii-ultimate-edition-vivowatch-sp-debut-at-ifa-2019-20190904/&title=ASUS ROG Phone II Ultimate Edition, VivoWatch SP debut at IFA 2019">
                                        <div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
                                        <div class="td-social-but-text">ReddIt</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_uid_1_5d707c1b40cb6">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>                        <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://androidcommunity.com/author/reah/">Rei Padla</a></span></div>	        <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Rei Padla"></span><meta itemprop="datePublished" content="2019-09-04T20:40:33+00:00"><meta itemprop="dateModified" content="2019-09-04T20:38:12-05:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://androidcommunity.com/asus-rog-phone-ii-ultimate-edition-vivowatch-sp-debut-at-ifa-2019-20190904/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://static.androidcommunity.com/images/aclogo.png"></span><meta itemprop="name" content="Android Community"></span><meta itemprop="headline " content="ASUS ROG Phone II Ultimate Edition, VivoWatch SP debut at IFA 2019"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://edge.androidcommunity.com/wp-content/uploads/2019/09/ASUS-ROG-Phone-II-Europe.jpg"><meta itemprop="width" content="1280"><meta itemprop="height" content="800"></span>        </footer>

<div style="margin: 0 auto; padding: 3px 1px 18px 1px;"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-8065766046515397"
     data-ad-slot="2037707268"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>

<div style="clear:both;"></div>
   


<div id="disqus_thread"></div>
                                </div>
                            </div>
                            <div class="td-pb-span4 td-main-sidebar" role="complementary">
                                <div class="td-ss-main-sidebar">
                                    <aside class="td_block_template_1 widget widget_text">			<div class="textwidget"><div style="text-align: center; padding: 10px 0px; background-color: #ddd;">
<!-- begin ad tag (tile=2) -->
<div data-ns="halfpage"></div>
<!-- end ad tag -->
</div>


</div>
		</aside>                                </div>
                            </div>
                                    </div> <!-- /.td-pb-row -->
        </article> <!-- /.post -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Footer -->
<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="td-subfooter-menu"><li id="menu-item-137251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-137251"><a href="https://androidcommunity.com/about/">About</a></li>
<li id="menu-item-137253" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-137253"><a href="https://androidcommunity.com/contact/">Contact</a></li>
<li id="menu-item-137250" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-137250"><a href="https://androidcommunity.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-137249" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-137249"><a href="https://androidcommunity.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-137252" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-137252"><a href="https://androidcommunity.com/advertise/">Advertise</a></li>
<li id="menu-item-137257" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-137252"><a href="https://androidcommunity.com/feed/">RSS Feed</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                   &copy; 2008 - 2019 Android Community</div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->



    <!--

        Theme: Newspaper by tagDiv.com 2017
        Version: 8.7.2 (rara)
        Deploy mode: deploy
        
        uid: 5d707c1b41326
    -->

    
<!-- Custom css form theme panel -->
<style type="text/css" media="screen">
/* custom css theme panel */
.grecaptcha-badge{
	visibility: collapse !important;  
}


/* custom responsive css from theme panel (Advanced CSS) */
@media (min-width: 1141px) {
    .td-banner-wrap-full, .td-header-menu-wrap-full {
    background-color: #f9f9f9;
    padding-bottom: 0px; }
 .td-post-template-3 .td-post-header-holder {
    margin-top: 20px;
}   

.banner-top {padding-bottom: 10px;}
    

}


/* custom responsive css from theme panel (Advanced CSS) */
@media (min-width: 1019px) and (max-width: 1140px) {
.td-banner-wrap-full, .td-header-menu-wrap-full {
    background-color: #f9f9f9;
    padding-bottom: 0px; }
 .td-post-template-3 .td-post-header-holder {
    margin-top: 20px;
}   

.banner-top {padding-bottom: 10px;}
    

}


/* custom responsive css from theme panel (Advanced CSS) */
@media (min-width: 768px) and (max-width: 1018px) {
.td-banner-wrap-full, .td-header-menu-wrap-full {
    background-color: #f9f9f9;
    padding-bottom: 0px; }
 .td-post-template-3 .td-post-header-holder {
    margin-top: 20px;
}   

.banner-top {padding-bottom: 10px;}
    

}
</style>

<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"androidcom"};
/* ]]> */
</script>
<script type='text/javascript' src='https://edge.androidcommunity.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"390201 https:\/\/androidcommunity.com\/?p=390201","disqusShortname":"androidcom","disqusTitle":"ASUS ROG Phone II Ultimate Edition, VivoWatch SP debut at IFA 2019","disqusUrl":"https:\/\/androidcommunity.com\/asus-rog-phone-ii-ultimate-edition-vivowatch-sp-debut-at-ifa-2019-20190904\/","postId":"390201"};
/* ]]> */
</script>
<script type='text/javascript' src='https://edge.androidcommunity.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201936'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6LearJ4UAAAAAIOVzvTd5BGyvBOyeyAC1oO0CNgR&#038;ver=3.0'></script>
<script type='text/javascript' src='https://edge.androidcommunity.com/wp-content/themes/ac87/js/tagdiv_theme.min.js?ver=8.7.2'></script>
<script type='text/javascript' src='https://edge.androidcommunity.com/wp-includes/js/wp-embed.min.js?ver=5.2.2'></script>
<script type="text/javascript">
( function( grecaptcha, sitekey, actions ) {

	var wpcf7recaptcha = {

		execute: function( action ) {
			grecaptcha.execute(
				sitekey,
				{ action: action }
			).then( function( token ) {
				var forms = document.getElementsByTagName( 'form' );

				for ( var i = 0; i < forms.length; i++ ) {
					var fields = forms[ i ].getElementsByTagName( 'input' );

					for ( var j = 0; j < fields.length; j++ ) {
						var field = fields[ j ];

						if ( 'g-recaptcha-response' === field.getAttribute( 'name' ) ) {
							field.setAttribute( 'value', token );
							break;
						}
					}
				}
			} );
		},

		executeOnHomepage: function() {
			wpcf7recaptcha.execute( actions[ 'homepage' ] );
		},

		executeOnContactform: function() {
			wpcf7recaptcha.execute( actions[ 'contactform' ] );
		},

	};

	grecaptcha.ready(
		wpcf7recaptcha.executeOnHomepage
	);

	document.addEventListener( 'change',
		wpcf7recaptcha.executeOnContactform, false
	);

	document.addEventListener( 'wpcf7submit',
		wpcf7recaptcha.executeOnHomepage, false
	);

} )(
	grecaptcha,
	'6LearJ4UAAAAAIOVzvTd5BGyvBOyeyAC1oO0CNgR',
	{"homepage":"homepage","contactform":"contactform"}
);
</script>

<!-- JS generated by theme -->

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://androidcommunity.com/wp-content/themes/ac87/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://edge.androidcommunity.com/wp-content/themes/ac87';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>

<script type='text/javascript' src='https://stats.wp.com/e-201936.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.6',blog:'4653462',post:'390201',tz:'-5',srv:'androidcommunity.com'} ]);
	_stq.push([ 'clickTrackerInit', '4653462', '390201' ]);
</script>


</body>
</html>
<!-- Dynamic page generated in 0.127 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2019-09-04 22:08:11 -->

<!-- Compression = gzip -->