<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Android P Developer Preview adds secure DNS option - Android Community</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://androidcommunity.com/xmlrpc.php" />
    <meta property="og:image" content="https://scdn.androidcommunity.com/wp-content/uploads/2018/04/android-p-2-1.png" /><link rel="icon" type="image/png" href="https://scdn.androidcommunity.com/wp-content/uploads/2016/09/ac_favicon.png">
<!-- All in One SEO Pack 2.5 by Michael Torbert of Semper Fi Web Design[208,285] -->
<meta name="description"  content="The development of Android P is slowly but surely taking shape, and you can check our coverage of that via the Android P tag. There are a number of new features that are aimed specifically at making Android P better, especially in the realm of making it more secure for Android users. One recent addition to the Android" />

<link rel="canonical" href="https://androidcommunity.com/android-p-developer-preview-adds-secure-dns-option-20180416/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Android Community &raquo; Feed" href="https://androidcommunity.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Android Community &raquo; Comments Feed" href="https://androidcommunity.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Android Community &raquo; Android P Developer Preview adds secure DNS option Comments Feed" href="https://androidcommunity.com/android-p-developer-preview-adds-secure-dns-option-20180416/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/androidcommunity.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Work+Sans%3A400%7COpen+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=8.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://scdn.androidcommunity.com/wp-content/themes/ac87/style.css?ver=8.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://scdn.androidcommunity.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.0' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js?ver=2.2.4'></script>
<link rel='https://api.w.org/' href='https://androidcommunity.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://androidcommunity.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://scdn.androidcommunity.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Nokia X mystery phone teased, may launch April 27 as a reboot' href='https://androidcommunity.com/nokia-x-mystery-phone-teased-may-launch-april-27-as-a-reboot-20180416/' />
<link rel='shortlink' href='https://androidcommunity.com/?p=349119' />
<link rel="alternate" type="application/json+oembed" href="https://androidcommunity.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fandroidcommunity.com%2Fandroid-p-developer-preview-adds-secure-dns-option-20180416%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://androidcommunity.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fandroidcommunity.com%2Fandroid-p-developer-preview-adds-secure-dns-option-20180416%2F&#038;format=xml" />
<link rel="canonical" href="https://androidcommunity.com/android-p-developer-preview-adds-secure-dns-option-20180416/" />
<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <link rel="amphtml" href="https://androidcommunity.com/android-p-developer-preview-adds-secure-dns-option-20180416/amp/">
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Android P Developer Preview adds secure DNS option" />
<meta property="og:url" content="https://androidcommunity.com/android-p-developer-preview-adds-secure-dns-option-20180416/" />
<meta property="og:description" content="The development of Android P is slowly but surely taking shape, and you can check our coverage of that via the Android P tag. There are a number of new features that are aimed specifically at makin…" />
<meta property="article:published_time" content="2018-04-16T13:00:13+00:00" />
<meta property="article:modified_time" content="2018-04-16T10:18:14+00:00" />
<meta property="og:site_name" content="Android Community" />
<meta property="og:image" content="https://scdn.androidcommunity.com/wp-content/uploads/2018/04/android-p-2-1.png" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="800" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@Androids" />
<meta name="twitter:text:title" content="Android P Developer Preview adds secure DNS option" />
<meta name="twitter:image" content="https://scdn.androidcommunity.com/wp-content/uploads/2018/04/android-p-2-1.png?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@Androids" />

<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

	        if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

	        if ( navigator.userAgent.indexOf("Edge") > -1 ) {
                htmlTag.className += ' ieEdge';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="https:\/\/androidcommunity.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=8.7.2";
var td_get_template_directory_uri="https:\/\/androidcommunity.com\/wp-content\/themes\/ac87";
var tds_snap_menu="";
var tds_logo_on_sticky="";
var tds_header_style="5";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#658c2e";
var tds_smart_sidebar="";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

         <script type="text/javascript" id="nsgpt" data-channel="homepage" src="https://cdn.nsstatic.net/ns/androidcommunity.com.js" async="true"></script>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-645197-4"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-645197-4');
</script>

<link rel='stylesheet' id='custom-css'  href='https://scdn.androidcommunity.com/wp-content/themes/ac87/customstyle.min.css' type='text/css' media='all' />
</head>

<body class="post-template-default single single-post postid-349119 single-format-standard android-p-developer-preview-adds-secure-dns-option global-block-template-1 single_template_3 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-container"><ul id="menu-main" class="td-mobile-main-menu"><li id="menu-item-287240" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-287240"><a href="https://androidcommunity.com/">Home</a></li>
<li id="menu-item-137039" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-137039"><a href="https://androidcommunity.com/section/reviews/">Reviews</a></li>
<li id="menu-item-246925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-246925"><a href="https://androidcommunity.com/tag/smartphone/">Phones</a></li>
<li id="menu-item-246926" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-246926"><a href="https://androidcommunity.com/tag/tablet/">Tablets</a></li>
<li id="menu-item-246928" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-246928"><a href="https://androidcommunity.com/tag/app/">Apps</a></li>
<li id="menu-item-288186" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-288186"><a href="https://androidcommunity.com/devices/">Devices</a></li>
<li id="menu-item-246929" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-246929"><a href="https://deals.androidcommunity.com/">Deals</a></li>
<li id="menu-item-246933" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-246933"><a href="https://androidcommunity.com/send-tips/">Tip Us</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://androidcommunity.com/search-results/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input type="hidden" name="cx" value="009851139337901005932:mt7aa3eyyzm" />
    <input type="hidden" name="cof" value="FORID:11" />
    <input type="hidden" name="ie" value="UTF-8" />
	<input type="hidden" name="sa" id="sa" />       
				<input id="td-header-search-mob" type="text" value="" name="q" id="q" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>

    
    
    <div id="td-outer-wrap" class="td-theme-wrap">
    
        <!--
Header style 5
-->


<div class="td-header-wrap td-header-style-5 ">
    
    <div class="td-header-top-menu-full td-container-wrap ">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	</div>
        <div class="td-header-sp-top-widget">
    
    
            </div>    </div>

<!-- LOGIN MODAL -->
        </div>
    </div>

    <div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap ">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-disable" href="https://androidcommunity.com/">
			<img class="td-retina-data" data-retina="https://scdn.androidcommunity.com/wp-content/uploads/2016/08/ac_mobileretina.png" src="https://scdn.androidcommunity.com/wp-content/uploads/2016/08/ac_mobile.png" alt="Android Community" title="Android Community"/>
		</a>
			<a class="td-header-logo td-sticky-disable" href="https://androidcommunity.com/">
			<img class="td-retina-data" data-retina="https://scdn.androidcommunity.com/wp-content/uploads/2016/08/aclogo_retina.png" src="https://scdn.androidcommunity.com/wp-content/uploads/2016/08/aclogo.png" alt="Android Community" title="Android Community"/>
			<span class="td-visual-hidden">Android Community</span>
		</a>
	    </div>
    <div class="menu-main-container"><ul id="menu-main-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-287240"><a href="https://androidcommunity.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-137039"><a href="https://androidcommunity.com/section/reviews/">Reviews</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-246925"><a href="https://androidcommunity.com/tag/smartphone/">Phones</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-246926"><a href="https://androidcommunity.com/tag/tablet/">Tablets</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-246928"><a href="https://androidcommunity.com/tag/app/">Apps</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-288186"><a href="https://androidcommunity.com/devices/">Devices</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-246929"><a href="https://deals.androidcommunity.com/">Deals</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-246933"><a href="https://androidcommunity.com/send-tips/">Tip Us</a></li>
</ul></div></div>


    <div class="header-search-wrap">
        <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>

        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://androidcommunity.com/search-results/"">
                <div role="search" class="td-head-form-search-wrap">
<input type="hidden" name="cx" value="009851139337901005932:mt7aa3eyyzm" />
    <input type="hidden" name="cof" value="FORID:11" />
    <input type="hidden" name="ie" value="UTF-8" />
	<input type="hidden" name="sa" id="sa" />       
					<input id="td-header-search" type="text" value="" name="q" id="q" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    </div>
            </div>
        </div>
    </div>

            <div class="td-header-header-full td-banner-wrap-full td-container-wrap ">
            <div class="td-container-header td-header-row td-header-header">
                <div class="td-header-sp-recs">
                    <div class="td-header-rec-wrap">
    <div class="td-a-rec td-a-rec-id-header  td-rec-hide-on-p td_uid_1_5ad4a79289aca_rand td_block_template_1"><div class="ziffad-wrapper"><!-- begin ad tag (tile=1) -->
 <div data-ns="billboard"></div>
<!-- end ad tag -->
</div></div>
</div>                </div>
            </div>
        </div>
    
</div><article id="post-349119" class="td-post-template-3 post-349119 post type-post status-publish format-standard has-post-thumbnail hentry category-archive tag-android tag-android-p tag-dns td-container-wrap" itemscope itemtype="https://schema.org/Article">
    <div class="td-post-header td-container">
        <div class="td-crumb-container"></div>
        <div class="td-post-header-holder td-image-gradient">
            <div class="td-post-featured-image"><img width="1068" height="712" class="entry-thumb" src="https://scdn.androidcommunity.com/wp-content/uploads/2018/04/android-p-2-1-1068x712.png" srcset="https://scdn.androidcommunity.com/wp-content/uploads/2018/04/android-p-2-1-1068x712.png 1068w, https://scdn.androidcommunity.com/wp-content/uploads/2018/04/android-p-2-1-600x400.png 600w, https://scdn.androidcommunity.com/wp-content/uploads/2018/04/android-p-2-1-768x512.png 768w, https://scdn.androidcommunity.com/wp-content/uploads/2018/04/android-p-2-1-1024x683.png 1024w, https://scdn.androidcommunity.com/wp-content/uploads/2018/04/android-p-2-1-696x464.png 696w, https://scdn.androidcommunity.com/wp-content/uploads/2018/04/android-p-2-1-630x420.png 630w, https://scdn.androidcommunity.com/wp-content/uploads/2018/04/android-p-2-1.png 1200w" sizes="(max-width: 1068px) 100vw, 1068px" alt="" title="android-p-2"/></div>
            <header class="td-post-title">
                                <h1 class="entry-title">Android P Developer Preview adds secure DNS option</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://androidcommunity.com/author/johnh/">John Hoff</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-04-16T08:00:13+00:00" >April 16, 2018</time></span>                                        <div class="td-post-comments"><a href="https://androidcommunity.com/android-p-developer-preview-adds-secure-dns-option-20180416/#respond"><i class="td-icon-comments"></i>0</a></div>                </div>

            </header>
        </div>
    </div>

    <div class="td-container">
        <div class="td-pb-row">
                                <div class="td-pb-span8 td-main-content" role="main">
                        <div class="td-ss-main-content">
                            
    
    <div class="td-post-content">
        <p>The development of <strong>Android P</strong> is slowly but surely taking shape, and you can check our coverage of that via the <a href="https://androidcommunity.com/tag/android-p/">Android P</a> tag. There are a number of new features that are aimed specifically at making Android P better, especially in the realm of <a href="https://androidcommunity.com/android-p-will-block-apps-from-sending-unsecure-internet-traffic-20180411/">making it more secure</a> for Android users. One recent addition to the Android P Developer Preview is DNS over TLS, which is a secure way of handling domain name queries from your device.</p>
<p></p>
<p><span id="more-349119"></span></p>
<p>Browsing the internet from an Android device will mean that your device will need to make a DNS query (domain name server), which is needed to convert a friendly website name like <em>google.com</em> or <em>androidcommunity.com</em> to an IP address (like <code>159.65.64.37</code> or <code>2607:f8b0:4006:80e::2004</code>) so that the device knows the destination server and it can connect to it. Usually, these DNS services are provided by your internet service provider, but are most times unsecure – in that ISP-based DNS keeps logs of the sites you query.</p>

 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_inline td_uid_2_5ad4a7928ba13_rand td_block_template_1 ">
<script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="5135832846"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="5135832846"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="5135832846"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="5135832846"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

<p><img src="https://scdn.androidcommunity.com/wp-content/uploads/2018/04/updated_tls_img2.png" alt="" width="900" height="758" class="alignnone size-full wp-image-349121" srcset="https://scdn.androidcommunity.com/wp-content/uploads/2018/04/updated_tls_img2.png 900w, https://scdn.androidcommunity.com/wp-content/uploads/2018/04/updated_tls_img2-499x420.png 499w, https://scdn.androidcommunity.com/wp-content/uploads/2018/04/updated_tls_img2-768x647.png 768w, https://scdn.androidcommunity.com/wp-content/uploads/2018/04/updated_tls_img2-696x586.png 696w" sizes="(max-width: 900px) 100vw, 900px" /></p>
<p><strong>DNS over TLS</strong> is a protocol which establishes a secure channel to a secure DNS server. This protocol ais now included in Android P Developer Preview so that DNS queries and responses can&#8217;t be read or modified by anyone else who might be monitoring the connection. </p>
<p>You can now toggle between Private DNS choices – off, automatic, or you can provide a secure DNS host name. Automatic means that the device will upgrade to DNS over TLS if a network&#8217;s DNS server supports it.</p>
<p>SOURCE: <a href="https://android-developers.googleblog.com/2018/04/dns-over-tls-support-in-android-p.html" rel="noopener" target="_blank">Google</a></p>
<div class="related-posts">
<div id="related-posts-MRP_all" class="related-posts-type">
<h4>Story Timeline</h4>
<ul class="st-related-posts">
<li><a href="https://androidcommunity.com/android-p-will-prevent-idle-apps-from-recording-using-devices-microphone-20180221/">Android P will prevent idle apps from recording using device’s microphone</a></li>
<li><a href="https://androidcommunity.com/android-p-brings-a-native-screenshot-editor-heres-how-to-get-it-20180309/">Android P brings a native screenshot editor, here's how to get it</a></li>
<li><a href="https://androidcommunity.com/android-p-will-block-apps-from-sending-unsecure-internet-traffic-20180411/">Android P will block apps from sending unsecure internet traffic</a></li>
<li><a href="https://androidcommunity.com/android-ps-navigation-changing-pill-button-may-be-for-swipe-up-gestures-20180415/">Android P’s navigation changing, pill button may be for swipe up gestures</a></li>
</ul></div>
</div>

 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_bottom td_uid_3_5ad4a7928bc41_rand td_block_template_1 ">
<script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="2596892046"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="2596892046"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="2596892046"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="2596892046"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

    </div>


    <footer>
                
        <div class="td-post-source-tags">
            <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://androidcommunity.com/tag/android/">Android</a></li><li><a href="https://androidcommunity.com/tag/android-p/">Android P</a></li><li><a href="https://androidcommunity.com/tag/dns/">DNS</a></li></ul>        </div>

        <div class="td-post-sharing-bottom"><div id="td_uid_4_5ad4a7928bff4" class="td-post-sharing td-ps-bg td-ps-padding td-ps-rounded td-post-sharing-style4 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fandroidcommunity.com%2Fandroid-p-developer-preview-adds-secure-dns-option-20180416%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Android+P+Developer+Preview+adds+secure+DNS+option&url=https%3A%2F%2Fandroidcommunity.com%2Fandroid-p-developer-preview-adds-secure-dns-option-20180416%2F&via=Android+Community">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-googleplus" href="https://plus.google.com/share?url=https://androidcommunity.com/android-p-developer-preview-adds-secure-dns-option-20180416/">
                                        <div class="td-social-but-icon"><i class="td-icon-googleplus"></i></div>
                                        <div class="td-social-but-text">Google+</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://androidcommunity.com/android-p-developer-preview-adds-secure-dns-option-20180416/&title=Android P Developer Preview adds secure DNS option">
                                        <div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div>
                                        <div class="td-social-but-text">Linkedin</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://androidcommunity.com/android-p-developer-preview-adds-secure-dns-option-20180416/&title=Android P Developer Preview adds secure DNS option">
                                        <div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
                                        <div class="td-social-but-text">ReddIt</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_uid_4_5ad4a7928bff4">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>                <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://androidcommunity.com/author/johnh/">John Hoff</a></span></div>        <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="John Hoff"></span><meta itemprop="datePublished" content="2018-04-16T08:00:13+00:00"><meta itemprop="dateModified" content="2018-04-16T05:18:14+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://androidcommunity.com/android-p-developer-preview-adds-secure-dns-option-20180416/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://scdn.androidcommunity.com/wp-content/uploads/2016/08/aclogo.png"></span><meta itemprop="name" content="Android Community"></span><meta itemprop="headline " content="Android P Developer Preview adds secure DNS option"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://scdn.androidcommunity.com/wp-content/uploads/2018/04/android-p-2-1.png"><meta itemprop="width" content="1200"><meta itemprop="height" content="800"></span>    </footer>

  <div class="td_block_wrap td_block_related_posts td-pb-border-top">
 <h4 class="block-title"><a id="must-read" class="td-related-left td-cur-simple-item" href="/section/must-read/">Must Read</a></h4>
 
 <div class="td_block_inner">

	<div class="td-related-row">
         

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://androidcommunity.com/huawei-p20-and-p20-pro-hands-on-ai-powered-photography-20180327/" rel="bookmark" title="Huawei P20 and P20 Pro hands-on: AI-powered photography"><img width="218" height="150" class="entry-thumb" src="https://scdn.androidcommunity.com/wp-content/uploads/2018/03/cover-huawei-p20-and-p20-pro-hands-on-ac-12-218x150.jpg" alt="" title="Huawei P20 and P20 Pro hands-on: AI-powered photography"/></a></div>                           
             </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://androidcommunity.com/huawei-p20-and-p20-pro-hands-on-ai-powered-photography-20180327/" rel="bookmark" title="Huawei P20 and P20 Pro hands-on: AI-powered photography">Huawei P20 and P20 Pro hands-on: AI-powered photography</a></h3> 
                </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->
         

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://androidcommunity.com/android-p-developer-preview-now-available-for-download-and-testing-20180307/" rel="bookmark" title="Android P Developer Preview now available for download and testing"><img width="218" height="150" class="entry-thumb" src="https://scdn.androidcommunity.com/wp-content/uploads/2018/03/Android-P-218x150.jpg" alt="" title="Android P Developer Preview now available for download and testing"/></a></div>                           
             </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://androidcommunity.com/android-p-developer-preview-now-available-for-download-and-testing-20180307/" rel="bookmark" title="Android P Developer Preview now available for download and testing">Android P Developer Preview now available for download and testing</a></h3> 
                </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->
         

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://androidcommunity.com/sony-xperia-xz2-xz2-compact-hands-on-time-for-a-change-20180226/" rel="bookmark" title="Sony Xperia XZ2, XZ2 Compact hands-on: time for a change"><img width="218" height="150" class="entry-thumb" src="https://scdn.androidcommunity.com/wp-content/uploads/2018/02/cover-sony-xperia-xz2-ac-38-218x150.jpg" alt="" title="Sony Xperia XZ2, XZ2 Compact hands-on: time for a change"/></a></div>                           
             </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://androidcommunity.com/sony-xperia-xz2-xz2-compact-hands-on-time-for-a-change-20180226/" rel="bookmark" title="Sony Xperia XZ2, XZ2 Compact hands-on: time for a change">Sony Xperia XZ2, XZ2 Compact hands-on: time for a change</a></h3> 
                </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->
  
	</div>
	
	</div>
	
		</div> <!-- ./block -->



<div id="disqus_thread"></div>
                        </div>
                    </div>
                    <div class="td-pb-span4 td-main-sidebar" role="complementary">
                        <div class="td-ss-main-sidebar">
                            <aside class="td_block_template_1 widget widget_text">			<div class="textwidget"><div style="text-align: center; padding: 5px; border: 1px solid #f2f2f2;">
<!-- begin ad tag (tile=2) -->
<div data-ns="halfpage"></div>
<!-- end ad tag -->
</div>

<br />
<div style="text-align: center; padding: 5px; border: 1px solid #f2f2f2;">
<!-- begin ad tag (tile=2) -->
<div data-ns="rectangle"></div>
<!-- end ad tag -->
</div>


</div>
		</aside><aside class="td_block_template_1 widget aps_new_arrivals">
<h4 class="block-title"><span>Latest Devices</span></h4>
			
			<ul class="aps-wd-products aps-row-mini clearfix"><!--
									--><li style="text-align:center; padding-bottom: 10px; border-bottom: 1px dotted #ddd; padding-top: 10px;">
						<a href="https://androidcommunity.com/product/xperia-xz2-compact/" title="Xperia XZ2 Compact">
							<span class="aps-wd-thumb">
																<img src="https://scdn.androidcommunity.com/wp-content/uploads/2018/02/sony-xperia-xz2-compact-product-image-120x120.jpg" alt="Xperia XZ2 Compact" />
							</span><br />							<span class="aps-wd-title" style="padding: 10px; margin-top: 5px;">Sony Xperia XZ2 Compact</span>
						</a><br />
					</li><!--
									--><li style="text-align:center; padding-bottom: 10px; border-bottom: 1px dotted #ddd; padding-top: 10px;">
						<a href="https://androidcommunity.com/product/xperia-xz2/" title="Xperia XZ2">
							<span class="aps-wd-thumb">
																<img src="https://scdn.androidcommunity.com/wp-content/uploads/2018/02/sony-xperia-xz2-product-image-120x120.jpg" alt="Xperia XZ2" />
							</span><br />							<span class="aps-wd-title" style="padding: 10px; margin-top: 5px;">Sony Xperia XZ2</span>
						</a><br />
					</li><!--
									--><li style="text-align:center; padding-bottom: 10px; border-bottom: 1px dotted #ddd; padding-top: 10px;">
						<a href="https://androidcommunity.com/product/galaxy-s9-2/" title="Galaxy S9+">
							<span class="aps-wd-thumb">
																<img src="https://scdn.androidcommunity.com/wp-content/uploads/2018/02/samsung-galaxy-s9-plus-product-image-120x120.jpg" alt="Galaxy S9+" />
							</span><br />							<span class="aps-wd-title" style="padding: 10px; margin-top: 5px;">Samsung Galaxy S9+</span>
						</a><br />
					</li><!--
							--></ul>
			</aside>
                        </div>
                    </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</article> <!-- /.post -->

<!-- Footer -->
<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="td-subfooter-menu"><li id="menu-item-137251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-137251"><a href="https://androidcommunity.com/about/">About</a></li>
<li id="menu-item-137253" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-137253"><a href="https://androidcommunity.com/contact/">Contact</a></li>
<li id="menu-item-137250" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-137250"><a href="https://androidcommunity.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-137249" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-137249"><a href="https://androidcommunity.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-137252" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-137252"><a href="https://androidcommunity.com/advertise/">Advertise</a></li>
<li id="menu-item-137257" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-137252"><a href="https://androidcommunity.com/feed/">RSS Feed</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                   &copy; 2008 - 2018 Android Community</div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->



    <!--

        Theme: Newspaper by tagDiv.com 2017
        Version: 8.7.2 (rara)
        Deploy mode: deploy
        
        uid: 5ad4a7928f840
    -->

    
<!-- Custom css form theme panel -->
<style type="text/css" media="screen">

/* custom responsive css from theme panel (Advanced CSS) */
@media (min-width: 1141px) {
    .td-banner-wrap-full, .td-header-menu-wrap-full {
    background-color: #f9f9f9;
    padding-bottom: 0px; }
 .td-post-template-3 .td-post-header-holder {
    margin-top: 20px;
}   

.banner-top {padding-bottom: 10px;}
    

}


/* custom responsive css from theme panel (Advanced CSS) */
@media (min-width: 1019px) and (max-width: 1140px) {
.td-banner-wrap-full, .td-header-menu-wrap-full {
    background-color: #f9f9f9;
    padding-bottom: 0px; }
 .td-post-template-3 .td-post-header-holder {
    margin-top: 20px;
}   

.banner-top {padding-bottom: 10px;}
    

}


/* custom responsive css from theme panel (Advanced CSS) */
@media (min-width: 768px) and (max-width: 1018px) {
.td-banner-wrap-full, .td-header-menu-wrap-full {
    background-color: #f9f9f9;
    padding-bottom: 0px; }
 .td-post-template-3 .td-post-header-holder {
    margin-top: 20px;
}   

.banner-top {padding-bottom: 10px;}
    

}
</style>

<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"androidcom"};
/* ]]> */
</script>
<script type='text/javascript' src='https://scdn.androidcommunity.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.15'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.15"},"disqusIdentifier":"349119 https:\/\/androidcommunity.com\/?p=349119","disqusShortname":"androidcom","disqusTitle":"Android P Developer Preview adds secure DNS option","disqusUrl":"https:\/\/androidcommunity.com\/android-p-developer-preview-adds-secure-dns-option-20180416\/","postId":"349119"};
/* ]]> */
</script>
<script type='text/javascript' src='https://scdn.androidcommunity.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.15'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201816'></script>
<script type='text/javascript' src='https://scdn.androidcommunity.com/wp-content/themes/ac87/js/tagdiv_theme.min.js?ver=8.7.2'></script>
<script type='text/javascript' src='https://scdn.androidcommunity.com/wp-includes/js/wp-embed.min.js?ver=4.9.5'></script>

<!-- JS generated by theme -->

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://scdn.androidcommunity.com/wp-content/themes/ac87/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://scdn.androidcommunity.com/wp-content/themes/ac87';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>

<script type='text/javascript' src='https://stats.wp.com/e-201816.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.0',blog:'4653462',post:'349119',tz:'-5',srv:'androidcommunity.com'} ]);
	_stq.push([ 'clickTrackerInit', '4653462', '349119' ]);
</script>


</body>
</html>
<!-- Dynamic page generated in 0.157 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2018-04-16 08:39:30 -->

<!-- super cache -->