<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Advanced Android App Development e-course available for willing learners - Android Community</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://androidcommunity.com/xmlrpc.php" />
    <meta property="og:image" content="https://scdn.androidcommunity.com/wp-content/uploads/2017/05/Advanced-Android-Course-3.jpg" /><meta name="author" content="Rei Padla">
<link rel="icon" type="image/png" href="https://scdn.androidcommunity.com/wp-content/uploads/2016/09/ac_favicon.png">
<!-- All in One SEO Pack 2.3.12.5 by Michael Torbert of Semper Fi Web Design[213,312] -->
<meta name="description"  content="If you can't go to this year's I/O 2017 conference, it's okay. Better luck next time and there will always be next year and the following years to come. But for" />

<link rel="canonical" href="https://androidcommunity.com/advanced-android-app-development-e-course-available-for-willing-learners-20170509/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Android Community &raquo; Feed" href="https://androidcommunity.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Android Community &raquo; Comments Feed" href="https://androidcommunity.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Android Community &raquo; Advanced Android App Development e-course available for willing learners Comments Feed" href="https://androidcommunity.com/advanced-android-app-development-e-course-available-for-willing-learners-20170509/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/androidcommunity.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.4"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='font-awesome-css'  href='https://scdn.androidcommunity.com/wp-content/plugins/silicon-counters/framework/assets/font-awesome/css/font-awesome.min.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Work+Sans%3A400%7COpen+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=7.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://scdn.androidcommunity.com/wp-content/themes/android/style.css?ver=7.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://scdn.androidcommunity.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.9' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js?ver=2.2.4'></script>
<link rel='https://api.w.org/' href='https://androidcommunity.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://androidcommunity.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://scdn.androidcommunity.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='OnePlus 3T Gunmetal 128GB version no longer for sale' href='https://androidcommunity.com/oneplus-3t-gunmetal-128gb-version-no-longer-for-sale-20170509/' />
<link rel='next' title='Race for the Galaxy is a strategy game, build your space empire' href='https://androidcommunity.com/race-for-the-galaxy-is-a-strategy-game-build-your-space-empire-20170509/' />
<link rel='shortlink' href='https://androidcommunity.com/?p=314007' />
<link rel="alternate" type="application/json+oembed" href="https://androidcommunity.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fandroidcommunity.com%2Fadvanced-android-app-development-e-course-available-for-willing-learners-20170509%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://androidcommunity.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fandroidcommunity.com%2Fadvanced-android-app-development-e-course-available-for-willing-learners-20170509%2F&#038;format=xml" />
<link rel="canonical" href="https://androidcommunity.com/advanced-android-app-development-e-course-available-for-willing-learners-20170509/" />
<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <link rel="amphtml" href="https://androidcommunity.com/advanced-android-app-development-e-course-available-for-willing-learners-20170509/amp/" />
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="https:\/\/androidcommunity.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.8.1";
var td_get_template_directory_uri="https:\/\/androidcommunity.com\/wp-content\/themes\/android";
var tds_snap_menu="";
var tds_logo_on_sticky="";
var tds_header_style="5";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#658c2e";
var tds_smart_sidebar="";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

    <meta property="fb:pages" content="201211916632255" />
    <script type="text/javascript" id="nsgpt" data-channel="homepage" src="https://cdn.nsstatic.net/ns/androidcommunity.com.js" async="true"></script>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-8065766046515397",
    enable_page_level_ads: true
  });
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-645197-4', 'auto');
  ga('send', 'pageview');

</script>
<link rel='stylesheet' id='custom-css'  href='https://scdn.androidcommunity.com/wp-content/themes/android/customstyle.min.css' type='text/css' media='all' />
</head>

<body class="post-template-default single single-post postid-314007 single-format-standard advanced-android-app-development-e-course-available-for-willing-learners global-block-template-1 single_template_3 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-container"><ul id="menu-main" class="td-mobile-main-menu"><li id="menu-item-287240" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-287240"><a href="https://androidcommunity.com/">Home</a></li>
<li id="menu-item-137039" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-137039"><a href="https://androidcommunity.com/section/reviews/">Reviews</a></li>
<li id="menu-item-246925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-246925"><a href="https://androidcommunity.com/tag/smartphone/">Phones</a></li>
<li id="menu-item-246926" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-246926"><a href="https://androidcommunity.com/tag/tablet/">Tablets</a></li>
<li id="menu-item-246928" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-246928"><a href="https://androidcommunity.com/tag/app/">Apps</a></li>
<li id="menu-item-288186" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-288186"><a href="https://androidcommunity.com/devices/">Devices</a></li>
<li id="menu-item-246929" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-246929"><a href="https://deals.androidcommunity.com/">Deals</a></li>
<li id="menu-item-246933" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-246933"><a href="https://androidcommunity.com/send-tips/">Tip Us</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://androidcommunity.com/search-results/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input type="hidden" name="cx" value="009851139337901005932:mt7aa3eyyzm" />
    <input type="hidden" name="cof" value="FORID:11" />
    <input type="hidden" name="ie" value="UTF-8" />
	<input type="hidden" name="sa" id="sa" />       
				<input id="td-header-search-mob" type="text" value="" name="q" id="q" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>

    
    
  <div id="td-outer-wrap">
    


<div class="td-header-wrap td-header-style-5">


    <div class="td-header-menu-wrap-full">
        <div class="td-header-menu-wrap">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-disable" href="https://androidcommunity.com/">
			<img class="td-retina-data" data-retina="https://scdn.androidcommunity.com/wp-content/uploads/2016/08/ac_mobileretina.png" src="https://scdn.androidcommunity.com/wp-content/uploads/2016/08/ac_mobile.png" alt="Android Community" title="Android Community"/>
		</a>
			<a class="td-header-logo td-sticky-disable" href="https://androidcommunity.com/">
			<img class="td-retina-data" data-retina="https://scdn.androidcommunity.com/wp-content/uploads/2016/08/aclogo_retina.png" src="https://scdn.androidcommunity.com/wp-content/uploads/2016/08/aclogo.png" alt="Android Community" title="Android Community"/>
			<span class="td-visual-hidden">Android Community</span>
		</a>
	    </div>
    <div class="menu-main-container"><ul id="menu-main-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-287240"><a href="https://androidcommunity.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-137039"><a href="https://androidcommunity.com/section/reviews/">Reviews</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-246925"><a href="https://androidcommunity.com/tag/smartphone/">Phones</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-246926"><a href="https://androidcommunity.com/tag/tablet/">Tablets</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-246928"><a href="https://androidcommunity.com/tag/app/">Apps</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-288186"><a href="https://androidcommunity.com/devices/">Devices</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-246929"><a href="https://deals.androidcommunity.com/">Deals</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-246933"><a href="https://androidcommunity.com/send-tips/">Tip Us</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="https://androidcommunity.com/search-results/">
				<div role="search" class="td-head-form-search-wrap">
				<input type="hidden" name="cx" value="009851139337901005932:mt7aa3eyyzm" />
    <input type="hidden" name="cof" value="FORID:11" />
    <input type="hidden" name="ie" value="UTF-8" />
	<input type="hidden" name="sa" id="sa" />       
					<input id="td-header-search" type="text" value="" name="q" id="q" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full">
        <div class="td-header-container td-header-row td-header-header">
            <div class="td-header-sp-recs">
           <div class="td-header-rec-wrap">
    <div class="td-a-rec td-a-rec-id-header td-rec-hide-on-p"><div class="ziffad-wrapper"><!-- begin ad tag (tile=1) -->
 <div data-ns="billboard"></div>
<!-- end ad tag -->
</div></div>
</div>       
            </div>
        </div>
    </div>

</div>


        <article id="post-314007" class="td-post-template-3 post-314007 post type-post status-publish format-standard has-post-thumbnail hentry category-archive tag-android tag-google tag-udacity td-container-wrap" itemscope itemtype="https://schema.org/Article">
    <div class="td-post-header td-container">
        <div class="td-crumb-container"></div>
        <div class="td-post-header-holder td-image-gradient">
            <div class="td-post-featured-image"><img width="1068" height="607" class="entry-thumb" src="https://scdn.androidcommunity.com/wp-content/uploads/2017/05/Advanced-Android-Course-3-1068x607.jpg" srcset="https://scdn.androidcommunity.com/wp-content/uploads/2017/05/Advanced-Android-Course-3-1068x607.jpg 1068w, https://scdn.androidcommunity.com/wp-content/uploads/2017/05/Advanced-Android-Course-3-600x341.jpg 600w, https://scdn.androidcommunity.com/wp-content/uploads/2017/05/Advanced-Android-Course-3-768x437.jpg 768w, https://scdn.androidcommunity.com/wp-content/uploads/2017/05/Advanced-Android-Course-3-1024x582.jpg 1024w, https://scdn.androidcommunity.com/wp-content/uploads/2017/05/Advanced-Android-Course-3-696x396.jpg 696w, https://scdn.androidcommunity.com/wp-content/uploads/2017/05/Advanced-Android-Course-3-739x420.jpg 739w, https://scdn.androidcommunity.com/wp-content/uploads/2017/05/Advanced-Android-Course-3.jpg 1400w" sizes="(max-width: 1068px) 100vw, 1068px" alt="" title="Advanced Android Course 3"/></div>
            <header class="td-post-title">
                                <h1 class="entry-title">Advanced Android App Development e-course available for willing learners</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://androidcommunity.com/author/reah/">Rei Padla</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-05-09T17:00:49+00:00" >May 9, 2017</time></span>                                        <div class="td-post-comments"><a href="https://androidcommunity.com/advanced-android-app-development-e-course-available-for-willing-learners-20170509/#comments"><i class="td-icon-comments"></i>1</a></div>                </div>

            </header>
        </div>
    </div>

    <div class="td-container">
        <div class="td-pb-row">
                                <div class="td-pb-span8 td-main-content" role="main">
                        <div class="td-ss-main-content">
                            
    <div class="td-post-sharing td-post-sharing-top ">
				<div class="td-default-sharing">
		            <a class="td-social-sharing-buttons td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fandroidcommunity.com%2Fadvanced-android-app-development-e-course-available-for-willing-learners-20170509%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Share on Facebook</div></a>
		            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Advanced+Android+App+Development+e-course+available+for+willing+learners&url=https%3A%2F%2Fandroidcommunity.com%2Fadvanced-android-app-development-e-course-available-for-willing-learners-20170509%2F&via=Android+Community"  ><i class="td-icon-twitter"></i><div class="td-social-but-text">Tweet on Twitter</div></a>
		            <a class="td-social-sharing-buttons td-social-google" href="https://plus.google.com/share?url=https://androidcommunity.com/advanced-android-app-development-e-course-available-for-willing-learners-20170509/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
		            <a class="td-social-sharing-buttons td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://androidcommunity.com/advanced-android-app-development-e-course-available-for-willing-learners-20170509/&amp;media=https://androidcommunity.com/wp-content/uploads/2017/05/Advanced-Android-Course-3.jpg&description=Advanced+Android+App+Development+e-course+available+for+willing+learners" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
		            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Advanced+Android+App+Development+e-course+available+for+willing+learners%20-%20https%3A%2F%2Fandroidcommunity.com%2Fadvanced-android-app-development-e-course-available-for-willing-learners-20170509%2F" ><i class="td-icon-whatsapp"></i></a>
	            </div></div>
    <div class="td-post-content">
        <p>If you can&#8217;t go to this year&#8217;s I/O 2017 conference, it&#8217;s okay. Better luck next time and there will always be next year and the following years to come. But for now, you can try improving your Android development skills further by studying and getting better at your craft. You can do self-study or sign-up for new e-courses like Google&#8217;s latest Advanced Android course.</p>
<p><span id="more-314007"></span></p>

 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_inline ">
<script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="5135832846"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="5135832846"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="5135832846"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="5135832846"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

<p>The online course was announced by the Android Training group&#8217;s Senior Program Manager Jocelyn Becker. She shared that the course has been recently updated. It&#8217;s well-improved and extended to help devs build more apps and learn advanced app development. You will learn how to make a mix-and-match game to build Android characters, a music quiz app, and a new app that makes use of widgets.</p>
<p>By the end of the course, you will also know the following:</p>
<p>• how to make apps aware of their location<br />
• how to use Google&#8217;s Mobile Vision API to recognize a smile or frown<br />
• how to use libraries<br />
• how to push notifications from a server to client apps via Firebase Cloud Messaging<br />
• how to test your user interface with Espresso<br />
• how to publish app to Google Play</p>
<p>As usual, Google and the Android team teamed up with <a href="https://androidcommunity.com/tag/udacity/">Udacity</a> course developers to prepare the lessons. If you want to be an expert Android developer, take this new e-course. That is, if you have already taken the earlier <a href="https://androidcommunity.com/udacity-updates-android-developer-course-better-resources-and-more-apps-to-build-20161201/">Developing Android Apps course</a>. Note that this course is also part of the <a href="https://androidcommunity.com/android-basics-nanodegree-is-an-android-developer-course-for-novices-20160623/" target="_blank" rel="noopener noreferrer">Udacity Android Developer Nanodegree</a>.</p>
<p>View more information about the course at <a href="https://www.udacity.com/course/ud855" target="_blank" rel="noopener noreferrer">Udacity</a>. It&#8217;s FREE.</p>
<div id='gallery-1' class='gallery galleryid-314007 gallery-columns-3 gallery-size-thumbnail'><figure class='gallery-item'>
			<div class='gallery-icon landscape'>
				<a href='https://scdn.androidcommunity.com/wp-content/uploads/2017/05/Advanced-Android-Course-3.jpg'><img width="200" height="200" src="https://scdn.androidcommunity.com/wp-content/uploads/2017/05/Advanced-Android-Course-3-200x200.jpg" class="attachment-thumbnail size-thumbnail" alt="" /></a>
			</div></figure><figure class='gallery-item'>
			<div class='gallery-icon portrait'>
				<a href='https://scdn.androidcommunity.com/wp-content/uploads/2017/05/Advanced-Android-Course-1.jpg'><img width="200" height="200" src="https://scdn.androidcommunity.com/wp-content/uploads/2017/05/Advanced-Android-Course-1-200x200.jpg" class="attachment-thumbnail size-thumbnail" alt="" /></a>
			</div></figure><figure class='gallery-item'>
			<div class='gallery-icon portrait'>
				<a href='https://scdn.androidcommunity.com/wp-content/uploads/2017/05/Advanced-Android-Course-2.jpg'><img width="200" height="200" src="https://scdn.androidcommunity.com/wp-content/uploads/2017/05/Advanced-Android-Course-2-200x200.jpg" class="attachment-thumbnail size-thumbnail" alt="" /></a>
			</div></figure>
		</div>

<p>SOURCE: <a href="http://android-developers.googleblog.com/2017/05/build-portfolio-of-apps-as-you-improve.html" target="_blank" rel="noopener noreferrer">Android Developers Blog</a></p>
<div class="related-posts">
<div id="related-posts-MRP_all" class="related-posts-type">
<h4>Story Timeline</h4>
<ul class="st-related-posts">
<li><a href="https://androidcommunity.com/google-teams-up-with-udacity-to-offer-android-nanodegree-program-20150602/">Google teams up with Udacity to offer Android Nanodegree program</a></li>
<li><a href="https://androidcommunity.com/google-udacity-bring-android-developer-nanodegree-program-in-india-20150922/">Google, Udacity bring Android Developer Nanodegree program in India</a></li>
<li><a href="https://androidcommunity.com/udacity-and-google-collaborate-brings-free-developer-classes-for-android-wear-20151022/">Udacity and Google collaborate, brings free developer classes for Android Wear</a></li>
<li><a href="https://androidcommunity.com/udacity-updates-android-developer-course-better-resources-and-more-apps-to-build-20161201/">Udacity updates Android Developer course, better resources and more apps to build</a></li>
</ul></div>
</div>

 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_bottom ">
<script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="2596892046"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="2596892046"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="2596892046"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8065766046515397" data-ad-slot="2596892046"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

    </div>


    <footer>
                
        <div class="td-post-source-tags">
            <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://androidcommunity.com/tag/android/">Android</a></li><li><a href="https://androidcommunity.com/tag/google/">Google</a></li><li><a href="https://androidcommunity.com/tag/udacity/">Udacity</a></li></ul>        </div>

                <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://androidcommunity.com/author/reah/">Rei Padla</a></span></div>        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Rei Padla"></span><meta itemprop="datePublished" content="2017-05-09T17:00:49+00:00"><meta itemprop="dateModified" content="2017-05-09T08:22:13+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://androidcommunity.com/advanced-android-app-development-e-course-available-for-willing-learners-20170509/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://scdn.androidcommunity.com/wp-content/uploads/2016/08/aclogo.png"></span><meta itemprop="name" content="Android Community"></span><meta itemprop="headline " content="Advanced Android App Development e-course available for willing learners"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://scdn.androidcommunity.com/wp-content/uploads/2017/05/Advanced-Android-Course-3.jpg"><meta itemprop="width" content="1400"><meta itemprop="height" content="796"></span>    </footer>
<div class="td_block_wrap td_block_related_posts td-pb-border-top">
 <h4 class="block-title"><a id="must-read" class="td-related-left td-cur-simple-item" href="/section/must-read/">Must Read</a></h4>
 
 <div class="td_block_inner">

	<div class="td-related-row">
         

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://androidcommunity.com/blackberry-keyone-review-20170504/" rel="bookmark" title="BlackBerry KEYone Review"><img width="218" height="150" class="entry-thumb" src="https://scdn.androidcommunity.com/wp-content/uploads/2017/05/blackberry-keyone-ac-16-218x150.jpg" alt="" title="BlackBerry KEYone Review"/></a></div>                           
             </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://androidcommunity.com/blackberry-keyone-review-20170504/" rel="bookmark" title="BlackBerry KEYone Review">BlackBerry KEYone Review</a></h3> 
                </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->
         

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://androidcommunity.com/samsung-galaxy-s8-review-20170418/" rel="bookmark" title="Samsung Galaxy S8 Review"><img width="218" height="150" class="entry-thumb" src="https://scdn.androidcommunity.com/wp-content/uploads/2017/04/samsung-galaxy-s8-ac-6-218x150.jpg" alt="" title="Samsung Galaxy S8 Review"/></a></div>                           
             </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://androidcommunity.com/samsung-galaxy-s8-review-20170418/" rel="bookmark" title="Samsung Galaxy S8 Review">Samsung Galaxy S8 Review</a></h3> 
                </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->
         

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://androidcommunity.com/huawei-watch-2-hands-on-20170418/" rel="bookmark" title="Huawei Watch 2 hands-on"><img width="218" height="150" class="entry-thumb" src="https://scdn.androidcommunity.com/wp-content/uploads/2017/04/huawei-watch-2-ac-6-218x150.jpg" alt="" title="Huawei Watch 2 hands-on"/></a></div>                           
             </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://androidcommunity.com/huawei-watch-2-hands-on-20170418/" rel="bookmark" title="Huawei Watch 2 hands-on">Huawei Watch 2 hands-on</a></h3> 
                </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->
  
	</div>
	
	</div>
	
		</div> <!-- ./block -->
		
		   <div style="padding-top:5px; padding-bottom: 8px;">		   
		   <script type="text/javascript">
amzn_assoc_placement = "adunit0";
amzn_assoc_search_bar = "false";
amzn_assoc_tracking_id = "slas0a-20";
amzn_assoc_search_bar_position = "top";
amzn_assoc_ad_mode = "search";
amzn_assoc_ad_type = "smart";
amzn_assoc_marketplace = "amazon";
amzn_assoc_region = "US";
amzn_assoc_title = "Related Deals";
amzn_assoc_default_search_phrase = "android";
amzn_assoc_default_category = "Electronics";
amzn_assoc_linkid = "24d602702cdd8fd3b0b900bd35437f0d";
amzn_assoc_rows = "1";
</script>
<script src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US"></script>
                </div>
                
                
		   <div style="padding-top:5px; padding-bottom: 8px;">
<div data-ns="native" data-sharethrough="ece01bec"></div>
</div>


<div id="disqus_thread">
    </div>

<script type="text/javascript">
var disqus_url = 'https://androidcommunity.com/advanced-android-app-development-e-course-available-for-willing-learners-20170509/';
var disqus_identifier = '314007 https://androidcommunity.com/?p=314007';
var disqus_container_id = 'disqus_thread';
var disqus_shortname = 'androidcom';
var disqus_title = "Advanced Android App Development e-course available for willing learners";
var disqus_config_custom = window.disqus_config;
var disqus_config = function () {
    /*
    All currently supported events:
    onReady: fires when everything is ready,
    onNewComment: fires when a new comment is posted,
    onIdentify: fires when user is authenticated
    */
    
    
    this.language = '';
        this.callbacks.onReady.push(function () {

        // sync comments in the background so we don't block the page
        var script = document.createElement('script');
        script.async = true;
        script.src = '?cf_action=sync_comments&post_id=314007';

        var firstScript = document.getElementsByTagName('script')[0];
        firstScript.parentNode.insertBefore(script, firstScript);
    });
    
    if (disqus_config_custom) {
        disqus_config_custom.call(this);
    }
};

(function() {
    var dsq = document.createElement('script'); dsq.type = 'text/javascript';
    dsq.async = true;
    dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>

                        </div>
                    </div>
                    <div class="td-pb-span4 td-main-sidebar" role="complementary">
                        <div class="td-ss-main-sidebar">
                            <aside class="td_block_template_1 widget widget_text">			<div class="textwidget"><div style="text-align: center; padding: 5px; border: 1px solid #f2f2f2;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- AC 300x250, created 11/10/08 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-8065766046515397"
     data-ad-slot="2356988882"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>

</div></div>
		</aside><aside class="td_block_template_1 widget widget_siliconcounters"><h4 class="block-title"><span>Community</span></h4><div style="background-color:#fff" class="silicon-counters-per-row-1  show-labels-No"><div class="silicon_counters"><ul class="sc_horizontal"><li class="count-facebook"><a data-color-hover="#5E80BF" style="background-color:#3B5998; padding:10px;" class="icon" href="https://www.facebook.com/AndroidCommunity" target="_blank" rel="nofollow"><span class="fa fa-fw fa-facebook-official" style="font-size:24px; color:#fff" data-color-hover="#fff"></span><span class="items"><span data-color-hover="#fff" class="count" style="font-size:16px; color:#fff">922.4k</span><span data-color-hover="#fff" class="label" style="font-size:12px; color:#fff">likes</span></span></a></li><li class="count-twitter"><a data-color-hover="#0084b4" style="background-color:#33ccff; padding:10px;" class="icon" href="https://twitter.com/androids" target="_blank" rel="nofollow"><span class="fa fa-fw fa-twitter" style="font-size:24px; color:#fff" data-color-hover="#fff"></span><span class="items"><span data-color-hover="#fff" class="count" style="font-size:16px; color:#fff">476k</span><span data-color-hover="#fff" class="label" style="font-size:12px; color:#fff">followers</span></span></a></li><li class="count-comments"><a data-color-hover="#f1f1f1" style="background-color:#f6f6f6; padding:10px;" class="icon" href="https://androidcommunity.com"><span class="fa fa-fw fa-comments" style="font-size:24px; color:#000" data-color-hover="#000"></span><span class="items"><span data-color-hover="#000" class="count" style="font-size:16px; color:#000">85.8k</span><span data-color-hover="#999999" class="label" style="font-size:12px; color:#999999">comments</span></span></a></li></ul></div></div><div class="siliconthemes"><div style="height:7px; margin-bottom:-7px; line-height: 3.7em !important; overflow: hidden;">/ Free WordPress Plugins and WordPress Themes by <a href="https://siliconthemes.com/">Silicon Themes</a>. Join us right now!</div></div></aside><aside class="td_block_template_1 widget widget_text">			<div class="textwidget"><div style="text-align: center; padding: 5px; border: 1px solid #f2f2f2;">
<!-- begin ad tag (tile=2) -->
<div data-ns="halfpage"></div>
<!-- end ad tag -->
</div>

<br />
<div style="text-align: center; padding: 5px; border: 1px solid #f2f2f2;">
<!-- begin ad tag (tile=2) -->
<div data-ns="rectangle"></div>
<!-- end ad tag -->
</div>


</div>
		</aside><aside class="td_block_template_1 widget aps_new_arrivals">
<h4 class="block-title"><span>Latest Devices</span></h4>
			
			<ul class="aps-wd-products aps-row-mini clearfix"><!--
									--><li style="text-align:center; padding-bottom: 10px; border-bottom: 1px dotted #ddd; padding-top: 10px;">
						<a href="https://androidcommunity.com/product/m8/" title="M8">
							<span class="aps-wd-thumb">
																<img src="https://scdn.androidcommunity.com/wp-content/uploads/2017/05/meitu-m8-product-image-120x120.jpg" alt="M8" />
							</span><br />							<span class="aps-wd-title" style="padding: 10px; margin-top: 5px;">Meitu M8</span>
						</a><br />
					</li><!--
									--><li style="text-align:center; padding-bottom: 10px; border-bottom: 1px dotted #ddd; padding-top: 10px;">
						<a href="https://androidcommunity.com/product/f3/" title="F3">
							<span class="aps-wd-thumb">
																<img src="https://scdn.androidcommunity.com/wp-content/uploads/2017/05/oppo-f3-product-image-120x120.jpg" alt="F3" />
							</span><br />							<span class="aps-wd-title" style="padding: 10px; margin-top: 5px;">Oppo F3</span>
						</a><br />
					</li><!--
									--><li style="text-align:center; padding-bottom: 10px; border-bottom: 1px dotted #ddd; padding-top: 10px;">
						<a href="https://androidcommunity.com/product/galaxy-j3-prime/" title="Galaxy J3 Prime">
							<span class="aps-wd-thumb">
																<img src="https://scdn.androidcommunity.com/wp-content/uploads/2017/05/samsung-galaxy-j3-prime-black-product-image-120x120.jpg" alt="Galaxy J3 Prime" />
							</span><br />							<span class="aps-wd-title" style="padding: 10px; margin-top: 5px;">Samsung Galaxy J3 Prime</span>
						</a><br />
					</li><!--
							--></ul>
			</aside>
                        </div>
                    </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</article> <!-- /.post -->

<!-- Footer -->
<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="td-subfooter-menu"><li id="menu-item-137251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-137251"><a href="https://androidcommunity.com/about/">About</a></li>
<li id="menu-item-137253" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-137253"><a href="https://androidcommunity.com/contact/">Contact</a></li>
<li id="menu-item-137250" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-137250"><a href="https://androidcommunity.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-137249" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-137249"><a href="https://androidcommunity.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-137252" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-137252"><a href="https://androidcommunity.com/advertise/">Advertise</a></li>
<li id="menu-item-137257" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-137252"><a href="https://androidcommunity.com/feed/">RSS Feed</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                   &copy; 2008 - 2017 Android Community</div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->

        <script type="text/javascript">
        // <![CDATA[
        var disqus_shortname = 'androidcom';
        (function () {
            var nodes = document.getElementsByTagName('span');
            for (var i = 0, url; i < nodes.length; i++) {
                if (nodes[i].className.indexOf('dsq-postid') != -1 && nodes[i].parentNode.tagName == 'A') {
                    nodes[i].parentNode.setAttribute('data-disqus-identifier', nodes[i].getAttribute('data-dsqidentifier'));
                    url = nodes[i].parentNode.href.split('#', 1);
                    if (url.length == 1) { url = url[0]; }
                    else { url = url[1]; }
                    nodes[i].parentNode.href = url + '#disqus_thread';
                }
            }
            var s = document.createElement('script');
            s.async = true;
            s.type = 'text/javascript';
            s.src = '//' + disqus_shortname + '.disqus.com/count.js';
            (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
        }());
        // ]]>
        </script>
        

    <!--

        Theme: Newspaper by tagDiv.com 2017
        Version: 7.8.1 (rara)
        Deploy mode: deploy
        
        uid: 59126f71a1757
    -->

    
<!-- Custom css form theme panel -->
<style type="text/css" media="screen">

/* custom responsive css from theme panel (Advanced CSS) */
@media (min-width: 1141px) {
    .td-banner-wrap-full, .td-header-menu-wrap-full {
    background-color: #f9f9f9;
    padding-bottom: 0px; }
 .td-post-template-3 .td-post-header-holder {
    margin-top: 20px;
}   

.banner-top {padding-bottom: 10px;}
    

}


/* custom responsive css from theme panel (Advanced CSS) */
@media (min-width: 1019px) and (max-width: 1140px) {
.td-banner-wrap-full, .td-header-menu-wrap-full {
    background-color: #f9f9f9;
    padding-bottom: 0px; }
 .td-post-template-3 .td-post-header-holder {
    margin-top: 20px;
}   

.banner-top {padding-bottom: 10px;}
    

}


/* custom responsive css from theme panel (Advanced CSS) */
@media (min-width: 768px) and (max-width: 1018px) {
.td-banner-wrap-full, .td-header-menu-wrap-full {
    background-color: #f9f9f9;
    padding-bottom: 0px; }
 .td-post-template-3 .td-post-header-holder {
    margin-top: 20px;
}   

.banner-top {padding-bottom: 10px;}
    

}
</style>

<link rel='stylesheet' id='silicon-counters-css'  href='https://scdn.androidcommunity.com/wp-content/plugins/silicon-counters/framework/assets/css/silicon-counters.css?ver=1.0' type='text/css' media='all' />
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201719'></script>
<script type='text/javascript' src='https://scdn.androidcommunity.com/wp-content/plugins/silicon-counters/framework/assets/js/silicon-counters.js?ver=1.0'></script>
<script type='text/javascript' src='https://scdn.androidcommunity.com/wp-content/themes/android/js/tagdiv_theme.js?ver=7.8.1'></script>
<script type='text/javascript' src='https://scdn.androidcommunity.com/wp-includes/js/wp-embed.min.js?ver=4.7.4'></script>

<!-- JS generated by theme -->

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://scdn.androidcommunity.com/wp-content/themes/android/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://scdn.androidcommunity.com/wp-content/themes/android';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>

<script type='text/javascript' src='https://stats.wp.com/e-201719.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.9',blog:'4653462',post:'314007',tz:'-5',srv:'androidcommunity.com'} ]);
	_stq.push([ 'clickTrackerInit', '4653462', '314007' ]);
</script>

<script type="text/javascript">
var clicky_site_ids = clicky_site_ids || [];
clicky_site_ids.push(100728648);
(function() {
  var s = document.createElement('script');
  s.type = 'text/javascript';
  s.async = true;
  s.src = '//static.getclicky.com/js';
  ( document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0] ).appendChild( s );
})();
</script>
<noscript><p><img alt="Clicky" width="1" height="1" src="//in.getclicky.com/100728648ns.gif" /></p></noscript>


</body>
</html>