Samsung Fascinate Update Axes SD Card Mounting

January 16, 2011
15

So you updated your phone a couple of days ago on your Samsung Fascinate, the update pushed out by Verizon, right? Have you tried to mount your SD card as a mass storage device to your desktop? Good luck! Users in several forums are noting a problem doing so, saying now that any attempt to mount their SD card ends up with no luck to be had.

There does seem to be on big giant monstrous list of a step by step you can take if you head over to [this post] in a thread in our pal Android Central's house, reproduced here for your convenience:

1) Unplug your Fascinate from the computer.
2) Download and install V CAST Media Manager. During the install process, when you are prompted for "If your phone requires a driver, select it from the list below", do not select anything. Instead click install and let it finish installing.
2) On Fascinate Go to settings > applications > development and uncheck USB Debugging.
3) On Fascinate Go to settings > USB settings > and check Mass storage.
4) Plug Fascinate into PC and run ToolLauncer-Bootstrap.exe
5) A popup will display in your system tray saying software is available that will help your Atlas (SCH-I500) communicate with your PC. Click Yes. It will now install USB drivers.
7.) Pull the notification panel down and select USB Connected: Select to copy files to/from your computer.
8.) A popup will display. Choose Mount.
9.) You card should now be mounted and a window should open displaying the contents of your SD card.

To unmount:
1.) Swipe down on the notification panel and select the option to turn off USB storage.
2.) Press the Turn Off button.
3.) Unplug Fascinate from your computer.

To remount in the future, plug your Fascinate in to your computer and repeat steps 7-9 above.

Yes this sucks, but it appears to be the only way to do it.

But if you're using a Mac, you might just be completely out of luck until Verizon grants the world a reprieve. In both cases, we expect more than one average, every day user is going to flip out and crash into a wall with rage before they realize it's the update that screwed up their phone - get ready for some phone calls, Verizon.

[Via Android Central]


Recent Stories

  • Carolyn

    OMG I thought it was just my phone. And lucky me I own a Mac…WTF VERIZON!!!

  • guest

    I use my Fascinate on both a Mac and PC. I noted the problem first on the Mac. When I connected, I got a Media Sync message that wouldn’t go away. I disconnected, did a battery pull, reconnected and noted that I had a CD Rom on my Mac screen that was my phone. Rather than install the software, I waited (approximately 30 seconds). The CD disappeared and USB connected message appeared in the notification bar with the option to mount my SD card (just like pre-update days). Same issue on my PC running Windows 7. Each time I connect I get this, but a little patience (30 seconds worth) and the USB connect comes back up in the message bar of my phone with the choice to mount my SD card. I did not install any of the optional software.

  • Tsaot

    Easier fix:
    1. Go to Settings -> USB Settings
    2. Select either Ask on Connection or Mass Storage.
    (connect a continue like normal:
    3. Swipe Notification Panel down
    4. Hit the USB message to mount)

    • a

      It doesn’t give you that option on the panel anymore.

    • Carson

      Holy hell, this worked!!! Thanks!!! I cannot tell you thanks enough!!!

  • Jesse

    I also own a Mac, and this is really screwing me up. My phone totally locked up this morning, which has never happened before.

    Tsaot – I discovered that trick today as well, however, it still does not load my SD card as a disk on my computer. This was how I managed files on my computer before, which was so easy and I loved it. Now its a mess!

    Anyone know how to “downgrade” – this update was bogus!

  • Carolyn

    guest, I did what you said. I did a battery pull, replugged it into my mac, and I waited. The mount option appeared on my notification bar, which I selected, but a notification on my Mac shows up saying “The disk you inserted was not readable by this computer.”

    Tsaot, that doesn’t work for me either :(

    My MacBook is over 3 years old; maybe that’s part of the problem?

  • Android

    Go over to XDA developers to learn how to downgrade to DJ05 … rooting, odin, etc required. And all at your own risk plus voiding that warranty!

  • http://www.nunyazz.com nunyazz

    Downgrading will not help you, I went all the way back to DI01, then DJ05 and still have the problem.

  • Jesse

    Other frustrations: After every picture I take, the phone does a “media scan” which stops my music from playing and slows down all process on the phone. This update is a piece of shit. Anyone found any helpful solutions or know the best way to get Verizon to fix these problems?

  • Zach

    This is bullcrap. I have a mac and I loved using my fascinate as a music player. I even put movies on it. This totally makes me regret getting this phone now, unless they fix this issue. Someone really screwed the pooch

  • Michael C

    Verizon constantly pull this crap. They have a great network but their software is amateurish at best. Every application I’ve used by them has been only 75% baked and usually has caused me a great deal of lost time. Also, Samsung made a deal with the devil with the way they outfitted the Fascinate. They should have just left the Android world to Google. Samsung made a very nice piece of hardware (except the GPS’s get locked pretty slowly) — they should have stuck to the great hardware and left the software to Google — and for God’s sake, left Microsoft out of the equation. Microsoft just hasn’t yet gotten a grasp of mobile software yet.

  • Leah

    I’m a Mac user and the only way I’ve found to transfer anything now is through a bluetooth connection. It’s a really roundabout way unfortunately. Took me a while to figure out, but I was happy when I finally got it working the way I wanted. Anyone else having issues with this or been using bluetooth?

  • Chuck (yes Norris)

    i agree with leah, im on a mac and i had to finally resorted to using bluetooth, i just heard that it was the update that caused it. im kinda frustrated now xD

  • Lauren

    This is how to do it. I just went through the wilderness for about three hours, but I did it.
    PS: I am on a Macbook.

    1: Reset your phone and computer. Always a great start.
    2: Go to Menu > Settings > USB Settings > Ask on Connection
    3: Plug in your phone to the USB port. It will ask you which USB mode you want. Click MASS STORAGE.
    4: At this point one of two things will happen: nothing, or an android with a USB for an arm will pop up on your screen.
         – If nothing happens, go to your desktop where you will see a CD icon has appeared. Click it.
    5: At this point, we should all be with the android. Click CONNECT USB STORAGE. Then click OK.
    6: NO NAME should now appear on your desktop. Voila! Use as you did before. :)
        – If it does not appear, switch USB ports on your computer. It might jog the little shit into working. That’s what I had to do, at least.

    TA DAAA.