T-Mobile prepaid customers may be able to enjoy free tethering

October 25, 2013
13

Interesting news from a T-Mobile forum discussion today, as it seems users are starting to get free tethering on their prepaid plans. While the freebie was originally spotted by a Cyanogen user who assumed it was due to his new ROM, others quickly chimed in noting they were seeing the same functionality.


Their $70/month plan is showing -- via the T-Moble “My Account” app -- 2.5GB free tethering monthly. Writer Andrew Martonik from Android Central notes his app shows 100MB free tethering, which is half of the allotment T-Mobile is now giving for tablets. He and I happen to have the same prepaid plan ($30/month, unlimited data), but a conversation with T-Mobile yielded me much different results.

In an online chat, and later a phone conversation, T-Mobile notes my prepaid $30/month plan is eligible for 5GB free hotspot tethering monthly. It’s worth noting that the plan offers 5GB of data at top speeds before throttling down. Normally, when tethering was activated, I’d need to call T-Mobile and pay $15/month for the pleasure. Now, it simply works without incident.

This could be phase four of the “Un-carrier” approach, or just a new feature they haven’t yet announced. Either way, it makes prepaid much, much more attractive. Spending a lot less versus a postpaid plan was already enough to keep us around, but free tethering is just going to make it that much better.


Recent Stories
  • Anthony S Jennings

    I use the $30/month plan with 100 talk minutes, and unlimited texts and data (with the first 5gb at higher speed). I used tethering on an unlocked phone since signing up. Day before yesterday I first noted the tethering “bucket” of 100mb. I haven’t yet tried it since this new information started showing, but I’m going to try to exceed the 100mb threshold to see what happens. I’d much prefer to access the entire 5gb, rather than be capped at 100mb!

    • Jared

      Please keep us posted. I’m interested in what happens over the 100 MB.

      • Anthony S Jennings

        After six days, I’ve tethered more than 1gb of data, and the “Mobile Hotspot Usage” item hasn’t budged off of it’s reading as it first appeared: 0.1mb/100.0mb. I’ve received no warnings from T-Mobile, and no requests/suggestions I pay extra for tethering.

        I’m starting to think this is a placeholder for the rollout of free data to tablets tomorrow, November 1. I’ll continue to monitor what happens once November hits.

      • Daniel Butler

        For me that 100 mb only seems to count data I’ve used on Windows. I hit the 100 and it started putting up “purchase hotspot service” pages. But my linux machine and chromecast can still access the internet and I’ve streamed about 2gb to my chromecast (no home internet this week, netflix over hotspot :D)

      • Anthony S Jennings

        At the time of my post, 100% of my tethering was via Bluetooth, so I thought it may have been ignoring the Bluetooth connect as real tethering. So after my minutes/data reset for the month, I tethered exclusively via WiFi. No change: Mobile Hotspot Usage still reads 0.0MB / 100.0MB. Essentially, free tethering on the Walmart/T-Mobile plan.

      • Daniel Butler

        Interesting. Thats not been my experience. I tethered 2GB this pay period (I had not internet at home for a week haha) but it did count data from windows browsers against the 100. Just browsers, and you can get around it with changing the useragent string.

  • Boogie Man

    I have the $70 unlimited and I enjoy free 3G tethering via Verizon iPhone 5 on tmobile network. Thanks T-Mobile!

  • Boogie Man

    So wait what? You have the $30 plan and you have 5gb of 3G data?? That’s so cheap I might switch from the $70 plan.

    • Daniel Butler

      Yep $30 unlimited data 5gb of 4g. Unlimited text. But this is the kicker- only 100 minutes of talking. After that it’s 10cents a minute. So if you talk alot consider a voip service or be prepared to pay more than $30 in the end.

  • Sally

    I’ve been getting free tethering on Simple Mobile’s $40 plan for awhile now. Their plans are cheaper than T-Mobile offical prepaid, too. Unfortunately, there is no truly unlimited option for 4G data with Simple Mobile. MetroPCS seems to be offering a $60 truly unlimited plan, and with an extra $5 charge you can get mobile hotspot, so still cheaper than T-Mobile ($65 vs $70). Overall, T-Mobile prepaid still doesn’t seem like a good enough deal :( Too bad because I would honestly much rather be on T-Mobile with their better customer service. Simple Mobile has notoriously terrible customer service. Fortunately, I havent had to deal with them much since I’ve never really had problems with my account anyway, though. T-Mobile’s $30 plan would be great at 5GB of data, but unfortunately I use way more voice than the measly 100 minutes alloted to that plan since my significant other is living in another state. The search for the best cheapest data plan continues…

  • Poochii

    Simple Mobile sucks!!! Flatout they are slow and very untrustworthy! Id never refer them to my swarn enemy

  • nematoda

    I’m not sure what’s happening. I noticed the 100mb tethering “bucket” (the term another user used) on my account information page. I tried it out, and it seemed to work. I tried it again the same day, and it didn’t work. As usual, I was directed back to a t-mobile sign up page for adding tethering to my plan. Tried a third time (today), and it worked. I was using my Nexus 7, and I was able to download magazine content (Flip, Economist), and update apps. I double checked to make sure I was connected to my phone. I was. I also checked to see data usage. Interestingly, nothing showed up on the 100 mb tethering “bucket,” but I did see an uptick on my regular 5GB data allotment.

    As I said, it’s strange. I’m still not sure if I have a free hotspot/tethering. I guess I’ll have to try a few more times.

  • Arman

    I have the same $30 a month plan but as of today (5-10-2014) I can’t seem to get the hotspot working. I connect and when I go to my connected devices browser I get redirected to tmobiles internet manager page. Is it my phone or are others having the same problem? How can I fix this? Thanks!