Nexus 4 users pestered by Android 4.3 upgrade issues

August 1, 2013
42

Sometimes, getting the latest, though not always the greatest, does have its price, a lesson that some Nexus 4 users are now learning. Google announced Android 4.3 last month and its eventual availability for Nexus devices, and indeed the upgrades did arrive as promised. But Nexus 4 users are discovering that upgrading to the latest iteration of Android might be more trouble than it's worth.

Reports are coming in from Google's forums about various issues across the board. Some are annoyances like slower performance, missing apps, or reception problems. Others are functional problems like missing multi-touch functionality or disappearing content. Some have also reported overheating when using the upgraded handset.

But these are the issues that plague only those who are able to actually get into their phones. There are more serious reports of being locked out of their phones because it isn't possible to enter their pass phrase. But even worse, there some who can't even get their units to boot properly, being stuck in an endless loop at the Google and boot splash screens.

Not everyone have had problems with their upgrade and the process has been smooth for some. Those who did experience issues will be able to do a factory reset to get their phones working again. Still, the amount of users reporting such major problems and Google's silence on the issue is worrying, leaving users no proper way to fix the issue. For now, it would be best to hold off from upgrading. And always do a backup before performing an upgrade.

VIA: SlashGear, Phones Review


Recent Stories

  • Michael Perez

    I haven’t had any issues using 4.3. However I do notice that some users try to clear the Google framework services data to force the update. I have found that process to screw up the phone instead. So I simply dropped in 4.3 which cleared all information in the process. Since then I haven’t had any issues so far and Wi-Fi + Bluetooth has been more stable for me. When on 4.2.2 I had random and very rare times which WiFi and Bluetooth simply did not work correctly and a power cycle was the only real way of fixing it. (Airplane mode didn’t work). Just my experience thus far.

  • Christian

    I upgraded my Nexus 7 yesterday, and things are going fine, but as a minor note has anyone else recieved the new wallpapers in the Wallpaper Chooser with this update, cause I sure didn’t.

  • lion7718

    I had to flash 4.3 because I kept failing the OTA install…but everything has been fine…it’s working great…I have no complaints. The touch screen is more responsive & the phone doesn’t get hot anymore.

  • Chris

    So many people tried that “google services framework” trick to force the OTA and completely jacked their devices and google accounts. Everyone I’ve seen that waited and installed the OTA as intended have had no issues whatsoever. It doesn’t seem to be an upgrade issue, it seems to be a stupidity issue.
    I did a normal OTA, and my device is 100% flawless. Every single issue I had with the N4 is GONE with 4.3. Best Android experience I’ve ever had. Period.

    • Mike

      Good for you. I am glad that you are not having any problems. However you are lucky and what you say is sadly untrue. I have a standard phone, not modified in any way. I didn’t ask for 4.3. I received a status message telling me it was ready and to plug in my charger to install it.. I did this and now I have a paper weight, all my recent photos are lost. I have been in contact with google and they have been trying fix it with boot loaders and factory resets but they have got nowhere. Now they say it has been damaged and needs to be replaced with a new phone. Please show some sympathy for what, I believe, are many in this situation rather than calling them stupid.

  • Tom B 91

    I’m stock and waited for the OTA update. By phone didn’t finish the install and crashed and was looping at the start screen. It’s completely unusable now. I’ve had go contact google for a replacement. :(

  • goofle

    I upgraded mine and it was stuck at the loading X screen. I had to download the Google nexus toolkit and revert back to the previous version as a flash and factory reset didn’t fix it.. Yes I lost my data… Not happy!!

  • Jorge A Salazar

    I have never rooted my Nexus 4 and when I installed the update, my phone got stuck at the boot X screen for a while. After about 30 minutes, I realized something was not working properly, so I pressed the power button for a few seconds to shut it down. Then I turned it on again and it finally completed the boot sequence. I was worried about what could have caused this “hiccup”, but my phone seems to be working fine now, except for a few applications that keep force closing.

  • Asgeir Misund

    I have had no problems what so ever

  • RSerda

    Recieved OTA last Friday… no problems here… runs smooth as glass…has all the bells and whistles of 4.3 JB.. all good!!
    Sux about all the issues reported… :/

    • Ahmed Awad

      Hey man, I also upgraded mine and everything runs fine, but does it heat when playing games? I know it’s normal, and it’s in the acceptable range of warmness, no problems in holding it, just to make sure, anything like this happened to you?

  • RSerda

    hmmm… not really… everything seems within the norm…? :0

  • Kellie Marsh

    Waited for OTA update to become available officially, waited a few days before installing…..Now when I finally install it gets stuck on install loop and, fails and wont start again…great!

  • Parag

    Got the 167 MB OTA update couple of days ago on my Nexus 4 in India. Everything went smoothly. No loss of data. Camera app works great with the ability to click photos with the volume rockers. Dial pad autocomplete works well, too. No issues with gaming / overheating as such.

  • Nate

    I did every troubleshooting option available, including factory reset. Still no luck. Still stuck on booting screen. Many people are having the same problem. Some have contacted google and are receiving replacements. I am currently waiting for google to process my claim. Pretty unfortunate.

    • Shaun

      you just need to flash the bootloader and radio back to 4.2.2 one’s
      and flash stock 4.2.2 rom

      so download this file “occam-jdq39-factory-345dc199.tgz” from google, make sure you have your device in fastboot and you have the “fastboot” file on your computer (youtube it if you don’t know what im talking about)
      open terminal or cmd
      and run these comands

      ./fastboot flash bootloader bootloader-mako-makoz10o.img
      ./fastboot reboot-bootloader
      sleep 5
      ./fastboot flash radio radio-mako-m9615a-cefwmazm-2.0.1700.48.img
      ./fastboot reboot-bootloader
      sleep 5
      ./fastboot -w update image-occam-jdq39.zip
      (for mac) and for the rest without the “./”

  • drew

    lost network connections after upgrade, only on some apps tho. Cant get into apps store, rbs app, words with friends and a few more …

    • melhiore

      See above, I bet you have lost paid apps??

  • Jose Paniagua

    no wonder there some apps i couldn’t find..

  • Pradeep

    I upgraded and now can’t download ANY app or even rate any on the play store!! Other parts are running fine!! Anybody else l faced this issue?

    • melhiore

      Go to settings, Accounts, remove your Google account, go to apps, stop play store process, clear cache and re-add your Google account. Sometimes N4 require reboot in order to work…. Had the same issue…

  • LiiIiikEaBau5

    My 3G was sucky and after upgrading to 4.3, it turned my 3G speed to something else.
    Im talkking about Netcom 3G – Norway!

  • Chris Lusk

    since I upgraded to 4.3 my camera wants to take pictures upside down . it seems like when you rotate the phone It does not recognize the movement and it takes to picture upside down I use my camera everyday and never had a problem until I downloaded the 4.3. for the time being I had to download a third party app for the camera… Not happy with this!!!

  • Mirza A.

    Well I was one of a few people who forced the update to my nexus 4, by clearing the data on “google services framework”, and when I rebooted my phone I couldn’t purchase apps from google play, and it seemed like it was freaking out, because the clock in the status bar kept disappearing and reappearing, and I factory resetted my phone, set up my account again, and then my phone was buttery smooth again, I can buy apps and now it’s running android 4.3, so it’s probably better to just wait for the OTA update directly from google (no matter long it takes), so you don’t experience these issues like I did.

  • Elmboughs

    For some reason I lost the phone and messages apps off the dock and had to put them on again from scratch. I use Apex Launcher with a widened, 7-icon dock so it probably wasn’t Google’s fault. No problems afterwards, performance seems fine. My feeling is battery life has improved measurably, possibly quite a bit.

  • Rajesh

    Received 167 mb OTA update. Installed and Restarted the phone when asked. Everything went smoothly. And now all, apps, games, camera working fine. My N4 become more responsive.
    To avoid any issues after installation, “DON’T FORGET TO RESTART THE PHONE FIRST”.
    Thanks

  • herb

    wifi icon and data icon doesn’t appear on toggle…have to restart phone to fix issue..batter life seems slightly worst but I shall see…

  • zdil

    The espy/mlb site is way more beautiful. Otherwise I have not noticed any different.

  • Darwin

    I have a galaxy nexus, after the update, If when I come back to my house or any other place with WIFI it doesn’t connect back automatically, I have to got to the wifi list and only when I’m at the list it begging to connect back to the network.

  • Andrew Chih

    How do I download 4.3? Sorry first android smartphone!

    • Josh

      I believe the consensus here is that you shouldn’t bother for now.

  • spaceace

    Absolute disaster. Mine got stuck in the Google x loop, couldn’t do anything with it. Fortunately a mate of mine was able to sort it, but required a factory reset. Lost loads. Can’t believe this release is being pushed, yet it’s clearly not ready on Google’s flagship phone.

    • Roshan

      hey, i am facing the same problem. Could to tell me how did it resolve?

  • Lo

    I’m not entirely sure if this problem is due to the recent software upgrade, but yesterday my phone just stopped working entirely. It was fully charged but could not turn it on! It remained this way until 24 hrs later it just spontaniously turned on. Has anyone else encountered this?

    • Sagar V Shankaraiah

      I have the same issue,

  • Stephen Marshall

    Google is a disgrace. The upgrade killed my phone. I can’t get anywhere with recovery mode or factory rest. Google customer care is pathetic, basically being very nice and understanding but doing nothing. Two reps have said they would help be get a new phone but after 6 days the “specialists” are still “looking into it”. I use this bloody useless thing for work!!!

  • Mike

    Hi, please see my post above. I promise you I have an in modified phone updated to 4.3 using the standard update process. The update errored in the middle of process (status bar at about 70%). I immediately called google (who I purchased the phone from). I haved done everything that they have asked exactly to attempt to recover – forced shutdown and retry, boot loader, fully discharge batter , mains power, factory reset, clear cache. Still stuck with a phone which locks on the google X start up and just gets hotter and hotter until the battery fails. Google are sending a new phone. The reason I believe others is that they describe exactly the same symptoms and on screen messages as I have on mine. I know my phone is fried and I can’t see why mine should be the only one.

  • Pratz

    I have no problem at all after the upgrade. Working like a charm. I guess most of the people who are facing the issues tried to force upgrade their devices by force stopping Google framework services method.

  • Sagar V Shankaraiah

    I am having lots of issues after the upgrade. I got this update last week (Auto update from google). After couple of day I was not able to charge the phone when the phone is switched on, later I found that the power toggle app was not compatible with Jelly bean 4.3. So I uninstalled it. Now my phone takes more than twice the time to charge and it discharges very quick. If the battery it less than 50% I can never rely on it, sometime it does not respond, sometimes the screen never goes to sleep mode and most times it simply dies. When I charge for sometime and switch on, it says battery is 0%. I want to do factory reset, will it take me to Ice cream sandwich?? if yes, how do I upgrade it 4.2.2 and not 4.3?

  • Ekaf Tnuocca

    The only issue I have had is that the Secure Browser plugin for “Good For Enterprise” is appearantly not yet supported on 4.3.

  • morph

    Couldn’t unlock the phone after the first restart. Had to use keys combination to restart the device. Now it’s OK.

  • vijay

    My phone upgraded to 4.3 from 4.2 few days before, touch was working fine.
    But, after another system update JWR66Y on 25th August 2013 applied on mobile created the issue, touch is un-responsive on some part of the screen ( i cannot type ‘n’ , ‘j’ for example.)
    5-6 mm thick vertical strip goes un-responsive to touch , cannot type alphabets falls in that area .. swipe breaks in that area.

    Please some one suggest if faced similar issue, what to do ?

    Phone reset works?
    How to downgrade to 4.2.2 OS ?
    How to just go back 1 level to where it was working fine ?

    Any other thoughts.. your reply is much appreciated.. thanks in advance