Nexus 4 seeing issues with the Android 4.4 update

November 25, 2013
68

If you have the Android 4.4 update for your Nexus 4, and are experiencing issues, you’re not alone. Some users are reporting that the Home button isn’t working properly, and the Settings toggle is also acting up. Even worse, there seems to be a broken dialer, too, rendering the device dangerously useless in some circumstances.

This doesn’t affect all devices, or updates, but it’s happening. While the above issues have yet to make an appearance in the Nexus forums, we found some other issues reported like a faulty microphone. The microphone issue has been noticed during search, video capture, and calls.

There are also a myriad of other issues being reported, like the camera not working. Android Police believes this stems from the OTA update from the latest version of Jellybean to KitKat, though we haven’t realized those issues with our Nexus 4. They’re reporting that the update from factory images that was posted last week is unaffected, though it’s not clear what leads them to that conclusion.

The fix? Total Recall. Doing a complete factory reset is the only way to effectively get things back on track, but that’s pretty inconvenient. While the tech-centric folks out there will have no issue with that, some who are less than savvy will have major issues, and may not be aware of how or what to do. Of course, we would wait for a patch from Google, but if the dialer is unusable, it’s best to simply hit Settings>Backup and reset>Factory data reset. Make sure your pics and other locally stored files are backed up to cloud storage or another method if you choose that, though.


Recent Stories
  • josealvarezn

    Problems Android 4.4 KitKat on Nexus 4:

    [1] Constant loss coverage issues and the only way back is sometimes the tickets or Nexus reboot mode 4.

    [2] Bluetooth peripherals are not allowed to lower the volume (default will increase the volume to maximum ) , found to be from 4.4.

    [3] Removing a widget or icon for an application letting down and releasing upwards , leaves the word “X Remove” red reflected on the screen , even to the widget ‘s default Google search away, if it opens the application launcher and return to the beginning , the text appears above the search engine (attached image).

    [4] When you share anything from an application to the list of applications not listed, but it shares with the latter that has been shared above. Do not even ask if you want to place the default share certain application . For example, now when you click the share button , I can only share Google+ .

    Other problems , such as the rotation of the camera coming from 4.2 remain the same. I was forced to do a “downgrade” to version 4.3 , and I conclude that it is impossible to use the device normally. :(

    • jersonf

      [1] I am in the UK and have not had coverage issues so far.

      [2] I use a Jabra Extreme 1 headset, the Bluetooth volume comes on screen and shows the volume going up and down along with the sound,phone volume remains as it was, what BT device are you using?

      [4] Settings –> apps —> press 3 dots (top right of screen) —> Reset app preferences.

      • josealvarezn

        BT Devices: Philips SBT30/37 and SoundBot® SB220!

      • jersonf

        I take it the problem is with the SoundBot? but that Philips SBT looks cool probably not what you wanted to hear :)

        Either way if your device does not work 4.3 –> 4.4 then it needs fixing because you will not be the only one.

      • josealvarezn

        Ehh! Do work, you two. First I tried the device from a friend and ran perfectly. Now I’m at 4.3 again and all is well with bluetooth. I have this problem since 4.4.

  • Jeff Chew

    I ended up flashing the factory image via the Unified Android Toolkit and seem to have no issues.

    • lion7718

      I did it with ADB about 2 hours ago.

  • David Kinder

    Hope they can fix this soon. Just realized just now that I can only share to my clipboard, a feature I use daily all the time. I may try a factory re-install. Had been thinking of rooting anyway, maybe having to wipe my phone is a good excuse.

    • swankmonsta

      You have to reset all your default apps./

      • josealvarezn

        That does not work, do not take them there. I tried it and nothing.

      • jersonf

        Actually it is correct, I had the problem on both my N4 & N7 so it is a KitKat bug for sure.

        Settings –> apps —> press 3 dots (top right of screen) —> Reset app preferences.

        This will reset all your default apps, do not waste time clearing defaults on individual apps via app info, that will not work, but the above will.

  • sean

    exchange mail sync is also HORRIBLY broken.

  • Robin

    My custom ringtone & notification does not work. Even when I have them I just got another ringeton that sounds bong or something. The ringtone & notification I used got copied. One of the copies work, but I can’t change to a new custom ringetone or notification.

    sry for bad english.

  • Joe

    Everything is working for me. Yesssss.

  • n4

    i knew it. glad that i’vs researched. gonna wait more.

  • sags85

    if only i got the 4.4 update for me N4…

  • DD

    Its a pain for me after kitkat. Lot of apps like email wiki amc app are sayins unfortunately stopped working. It happened 3-4 times that if not using the phone for half an hour its hanging and only way to fix is to force restart.

  • bob

    So about 3 hours ago I manually check for a software update on my Google nexus 4 and finally after waiting since the 13th it says waiting to download and it told me all about the new update but it still hasn’t updated yet I want to know why and it also says update available via WiFi until Nov 26 which is tomorrow I’m so angry I really want to know why it still hasn’t updated

    • Ken

      I am facing the same issue

      • mangesh

        same here

      • mangesh

        same screen for last 36 hrs

      • Din

        same here….
        need help.. anyone??

      • mangesh

        lg says its better to get the update done from the service centre…but lg in India as for now has no information about the update

    • TrollSoul

      ÌTurn on WiFi to download the update…

  • kidfrom_lambacity

    Android 4.4 kit Kay runs perfectly for me. It has a reduced battery drainage capacity compared to the like of jelly beans 4.3 but it is a pain in the ass why the connectivity arrows where removed from the network coverage icon area and the colour is bizzare white is the worst color for an OS but it is very good and fast . also I have to complain about the Google now on nexus 4 they should have made it all listening not that you must first be running Google now before using voice commands that pissinge off seeing Motox doing those stuffs .

  • Eva So

    oh, man. 4.4 kit kay just knocked my N4 down. I now ….cannot get into the system, I can only get in recovery mode. Who knows how to fix it?

    • Sukiman Tongkodu

      try using fastboot tools, its easy and safe way for flashing

  • Prasanna Jayananthan

    I’m experiencing a delay in dialer. I mean, when I tap a contact, there’s a delay about 1 or 2 seconds to make a call. Anyone having the same issue ? Any help would be appreciated.
    Thank you.

    • pankaj

      I am also experiencing the same issue. If you find a fix for it, do let me know.

      • Prasanna Jayananthan

        I installed an app to sync all my FB contacts. The app is “SYNC.ME” and it caused me the delay. because it have a feature called “In-call experience”. SO I uninstalled the app and now everything is working fine.

      • PreachJohn

        When the Dialer is loaded, would checking those 3 dot settings help? Talks about a 2 second pause.

  • http://picasaweb.google.com/JTHolroyd/TileStoneWork JessSayin

    Still waiting for the CyanogenMod version for this very reason. Stock Android is so ‘bare bones’ to me now.

  • Sukiman Tongkodu

    I don’t have any issue with my N4, running KK KRT16S OTA flashing with Fastboot tools.

    • Prasanna Jayananthan

      I also did the same. but there’s something wrong with the dialer in my device. wish I would not have updated to Kitkat :)

      • Sukiman Tongkodu

        are you coming from stock ROM?

      • Prasanna Jayananthan

        yes. i am still with the stock ROM

      • Sukiman Tongkodu

        try this in fastboot–>> fastboot format cache
        then reboot bootloader—>> fastboot reboot-bootloader.
        after that go to recovery, do a wipe data. reboot.
        remember to backup your data

      • Prasanna Jayananthan

        yes Sukiman, I did this. all other features are okay. but the only problem is this delay in making calls. I get frustrated in some times as it is taking about 2-3 seconds delay :( is there any setting to turn on/off dialing features ?

      • Sukiman Tongkodu

        have no idea with your problem, wait for google to make a patch for this, i see other N4 user have this and other is not. so weird.

      • Prasanna Jayananthan

        yeah. my friend have no probs like this. well. we’ll wait and see.
        Thanks for the tips mate :)

      • Prasanna Jayananthan

        Sukiman, I found out the problem.
        I installed an application to sync FB contacts. the app is SYNC.ME.
        in that app, there’s a option called In-call experience. i unchecked it and everything is okay now.
        thanks for the help :)

      • Theeta

        Did you try any different dialer app ?

      • Prasanna Jayananthan

        hmmm nope. i’ll try and let you know the difference. btw,
        whats the most preferred dialer app ??
        thanks :)

      • Prasanna Jayananthan

        Theeta, I found out the problem.
        I installed an application to sync FB contacts. the app is SYNC.ME.
        in that app, there’s a option called In-call experience. i unchecked it and everything is okay now.
        thanks for the help :)

    • PreachJohn

      Running same. ‘Settings’ stopped working suddenly. Trying to understand why.

  • sam wouters

    I’ve updated my N4 with the OTA update and have no issues. Only the issue with the USB connection to a computer or Mac that I have since the upgrade from 4.2.2 to 4.3 is still there.

  • Zewks

    The N4 is horrible about new updates. Mine lost touchscreen use and gyroscope with the 4.3 update. The only way to fix was the manually flash 4.2.2 back on to the device which was a total pain to do. I had hoped that 4.4 would bypass the 4.3 issues, but nope, now there are a bunch of new issues. Looks like ill be sticking with 4.2.2 since my phone works flawlessly with that installed. Fix your crap google.

  • JW

    My Nexus 4 is shuting down after the upgrade. To start it again I need to press volume down and start. After a while it shuts down again, and this problem is repeating many times during the day.

    • nexus4

      Same here.

      • JW

        Havet you find Amy solution to this? I have not!

    • shane

      same

  • RK

    Google chrome isnt working on one tap, i need go back and front to load Chrome on my nexus 4 and sometimes i just cant open the browser, after the 4.4 update. The other apps hang, cant go back from the app. Smart app protector fails to launch the app after unlocking…. Does Fast reboot help ?

    • PreachJohn

      Fast Reboot is an excellent App on Play Store. Has cleared things many times. For instance, NQ Android Booster has started to hang on closing. I hit the Home button. then Fast Reboot.

  • Ajay Nargas

    I am dead after updating to 4.4 . google chrome is behaving crazy. Lot of setting function from menu have diappeared. i have done factory reset also. GOOGl Please recall anf fix our nexus 4 devise. We dont know what to do.

  • Ariel Dahan

    So far so mostly good for me, except for a somewhat less responsive touchscreen leading to issues with typing properly… Other problem is with it breaking some custom widgets running from UCCW.

  • Ugyen Tshering

    Reading all ur comments ..now m confuse really to proceed update for mi nexus 4..where KK 4.4 update is still waiting …

  • Or

    I bought my NX4 3 week ago. since I’ve updated to KITKAT 4.4 (KRT16S) OTA, the battery runs out much faster. Does anyone else expirience that?

  • Krista

    I hope this gets fixed soon. Battery runs out quicker apps are freezing and shutting down, can’t move apps to the left but can move them to the right, home button doesnt work properly, Google chrome. I’m sure there is other stuff I dont use not working properly. When you use this phone for your business it renders your business down the drain. Gonna put the gorilla glass to the test soon and buy a new phone.

    • PreachJohn

      It also seems to me also connectivity is reduced on the Screen. Folders are extremely difficult to make. So non-responsive.
      And the white/gray Phone interface is so Elementary Grade School amateur and ugly. But that is so minor compared to some of the other horrendous problems I’ve experienced so far between 4.3 and 4.4. Those ones, after far, far too much effort are now under control.
      I bought the Nexus 4 to save lots of money, to avoid bloatware. Tho’ Google loads it to the brim with its own Crap and turns reams of it on by default to eat my Battery. And having the latest greatest Android OS 1st or so; to be Cutting Edge, unlocked and all, was another reason to buy in. Cutting Edge has turned out to be so Crappy Deep Disappointment for legions of Folk it seems.

  • Chris Osborn

    My Nexus 4 is stuck on the screen that asks for my pin number then tells me it is wrong – but it isn’t as proved by trying the sim card on another phone and my sp telling me the card isn’t locked on their system. Can’t get at settings to factory reset as I can’t get past this screen – I also had yesterday people being unable to hear me on calls and the mic icon was crossed through and I couldn’t change it – anyone got any bright ideas cos right now all I got is a useless piece of metal, glass and rubber in my hands!!

    • PreachJohn

      I was similarly ‘hooped’ when 4.4 wouldn’t let me access Settings. You have to be able to access Settings to repair Settings.To repair anything.
      WugFresh Nexus Root Toolkit/Flash Stock & Unroot/Soft-Bricked-BootLoop. Then If you have a problem with the correct Driver, it seems WinUSBCoInstaller.dll needs to be on the Computer. I downloaded it and installed it to System32, if Mini-SDK installed does not do it.
      I had a horrible time getting Wugfresh or Unified Toolkit to recognize the correct Driver. The times it would recognize and go on to installing the new OS, it would hang over and over.
      After uninstalling/clearing Drivers in Device Mgr. and USBDeview in Wugfresh, Reboot if the OS hangs while Installing. THAT was the key there. Hope this helps you recover your Phone.

  • Morris

    My Samsung Galaxy S3 dialer is not working with this new kitkat update. This is a little ridiculous why this software was pushed if you cant do what a phone is meant to do…Make calls. Has anyone figured out what this issue is all about? I would rather not do a factory reset and have to upload all my data?

  • Rupal

    I am using Nexus 4, today i upgraded my android version to 4.4.2. The upgrade was successful without any errors/warnings, but now my screen is not responding and not taking any inputs. I cannot unlock my screen, I cannot power off. Has anybody faced similar issue??

    • justin

      I’m a Nexus 4 user and i was happy with the recent update however eversince i have done factory reset and since that when call comes in and when i call out regardless if thru application still having an error.

  • Marina

    Does anyone get this message: “an error has occured while downloading the voice message. please try again.” If so, what can I do to fix it? It’s been giving me that “oops” message for more than a week.

    • Vanco

      any fix?

  • abulkay

    My nexus 4 isn’t syncing. to resolve this removedmy google accountand signed in again, this removed all my contact can’t sign in to g+. can anybody help me, is there away i can go back to 4.3 without resetting my phone

  • Craig Le Page

    BEWARE : I just realised that Android Bluetooth no longer works. This means Android ‘phones can’t be used hands-free whilst driving. Anybody know if they’ll fix this or do we need to get different ‘phones for work?