We already knew this was going down but you can now root your DROID Bionic using the simple one-click-root method found to work on a slew of other recent Motorola phones such as the Droid X2 and the Droid 3 all running on Moto’s latest Gingerbread builds. Last week we saw the Bionic was already rooted, but today we have instructions and the download for you.

This literally took me about 1 minute to download the latest Motorola drivers and another minute or two to actually root and it was a done deal. Now I’m free to fly around and do titanium backup’s and all that good stuff. Obviously this doesn’t fix or do anything with the bootloader “situation” but we’ll take root any day for now. Image thanks to kellex.


-Install Motorola drivers – [click here]
-Download the MotorolaOneClickRoot
-Plug phone into PC and select “Charge Only”
-Enable USB debugging
-Navigate to MotorolaOneClickRoot folder and run MotorolaOneClickRoot.exe.
-Just follow the instructions in the command window.
-Your phone will reboot along the way, unlock it when it finishes — ROOTED!

Quick, easy and simple right? We have heard a few rumors that the hole that was found to achieve root on most of these recent Motorola phones has been figured out my Motorola and they will be patching this shortly. While we can’t confirm this if you wish to stay rooted I’d be cautious of any OTA updates for now and make sure to check with popular DROID developers (or just watch Android Community) for more details on future updates.

Root that new Bionic and enjoy the freedom at hand.

[device id=1476]

[via RootzWiki]

  • josh284

    thank you.  worked without any problems

  • Sweet I just picked one of these up today at 10AM and was hoping it could root.  Now I just need to wait for cyanogen to crack the boot loader.

  • Darby

    So what do you mean by locked boot loader? Is this worth the risk on a brand new device so soon?

    • Nrcmd

      The root worked

  • Nismogtr600hp

    downloaded and installed drivers, then extracted oneclick root into a folder on the desktop and hooked my phone up to usb and clicked charge only and double clicked oneclickroot and it came up for a few seconds and an error popped up saying this program has encountered an error and needs to close

    • Nismogtr600hp

      ok, tried it on my laptop with windows 7 and it worked! sweet! rooted within 24 hours of ownership!

    • Just try it again.. edit nvm..

      Enjoy guys!

    • Just try it again.. edit nvm..

      Enjoy guys!

  • Jhauck3

    Has anyone figured out how to get wireless tether work once rooted?

    • Yes… there is a video on youtube on how to do it

  • Jhauck3

    Has anyone figured out how to get wireless tether work once rooted?

  • Klosea

    my bionic will not root! says adb is not valid internal or external command!

  • Xyzromain

    What the hell is an “exe”file?
    Any way to root this Linux phone using a Linux computer?

    • lolburg

      Like you don’t know what a .exe file is.

  • Adam

    There a way to unroot it using these files too?

  • is there a way to unroot device? or in case of disaster is there a way to go back to default?

  • I think there should be one.  I remember checking one blog that talks about unrooting device.  Do a Google search!

  • any unroot method from using this?

  • David quinn

    i used this method on my Bionic & all went well with the process, but neither Barnacle or Open Garden WiFi work.  any ideas how to get either of them to work?

    • Ccplacide

      hey just search in google android wireless tether on ur droid then u should see an app their. I use it on my droid X2 works great

  • Chris

    Thank you so much for the root process its so much easier to have internet but one question, on my ps3, i tried to connect to my droid. When i go to scan for internet, it cannot pick up my droid hotspot. I tried barnicle tether, open garden, and android tether hotspot apps but nothing works. Are there any methods or alternative methods to connecting my ps3 up?

    I tried using virtual router and connectivfy on my laptop but they dont work for some reason and if ur wondering y im using my droid to play my ps3 online, its because verizon did not put broadband on my road and wont for a long time


  • Hhh

    I ran the program and it just sits there in rebooting your phone.  It has been over 5 minutes

  • Ammar Khan

    It says that it was successful but where do i obtain superuser rights? i dont see any change now that its rooted. HELP this NOOBIE

    • Chris

      Wat phone do u hav?

  • MAT

    i ran the program and it said successfully rooted at the end.. i then got the sqlite app and it tells me that my phone is not rooted.. any suggestions

    • Chris

      Wat phone do you have?

  • WishItWorkedForMe

    Droid Bionic – followed steps per post. Indication of successful but no root after reboot of phone.

    • WishCameTrue

      Ok, so I had 5.5.893 and had to manually root the Bionic per instructions found at:
      http://androidforums.com/bionic-all-things-root/460668-can-i-re-root-after-5-8-894-broke-root.html. I just rebooted from the final step and see the Superuser icon. Also, when I first tried the oneclick method I had an older version of it. I downloaded the latest from Pete’s site: http://www.psouza4.com/droid3/ and at least got an error which indicated ADB could not gain root access. After finding zerg I ran adb manually:

      [*] Sending 185 zerglings …

      [+] Rush did it ! It’s a GG, man !
      [+] Killing ADB and restarting as root… enjoy!

      D:Download!!!!!rootPetesMotorolaRootTools_v1.07>adb shell
      root@cdma_targa:/# mount -o rw,remount /dev/null /system

  • Shain

    Where can I find the driver for 32 bit windows? On a quick Google search I only found places to download it that would require signing up with an account. (not happening, I get enough spam email) Why does my Motorola driver that worked with other Motorola phones not work with my Bionic? Also, why does this web page assume I am on a windows machine and using 64 bit. 64 bit is more common these days, but it is certainly not universal.

  • Rich Tung

    It doesn’t work anymore as of Jan 4t, 2012. I tried several version of Souza’s files.

  • this is not working for my Motorola Droid phone goes through the process and says congratulations your phone should be rooted but it is not ;-( .

  • Morty

    I tried 1/11/12 and not working on Bionic running 2.3.5 ….

  • Tom Love Gunner

    I have a Droid Bionic, ensured the USB Debugging was set correctly and it was in charge only and root failed.  This is the fourth procedure I have tried and it is not rooted.  End the end of one click it says it is rooted, but root check says it is not.  Suggestions?

  • Bucks_bulls

    is it possible to root the bionic wit out bricking it while tethered to the pc??

  • N8doggs

    Everything worked fine for me…Wifi teather, setcpu, liberty Kernel, with blue eclipse Rom…Everything is dandy thanks!

  • Lasergirl4

    The download for Motorola drivers consistently “fails”

    • Bryanchapman07

      because its a 64 bit, you probably have 32 bit

  • Scott

     I cannot get this method to work. My screen gives me the following errors:

    cannot create /data/local.prop: permission denied

    remount failed: Operation not permitted
    failed to copy ‘busybox’ to ‘/system/xbin/busybox’: Read-only file system
    failed to copy ‘su’ to ‘/system/xbin/su’: Read-only file system
    failed to copy ‘Superuser.apk’ to ‘/system/app/Superuser.apk’: Read-only file system