Motorola DROID Bionic receiving another hefty software update

December 20, 2011
18

It has only been about a week since Verizon and Motorola pushed that huge software update to the DROID Bionic that was set to fix the large list of problems, bugs, and camera issues that users were having and today they are continuing the fun. Another large update coming in around 56MB in size is rolling out to DROID Bionic users as we speak according to Droid Forums. We've been looking for more details but Verizon's keeping tight lipped on the update.

This latest over the air update that we don't know much about will bring the Bionic to build 5.9.901 and searching for a changelog hasn't been successful. A few users from our source link have claimed the update will kill root, and will prevent further root methods from working for those that like to tinker. If you run with a completely stock phone and don't need root access then feel free to update away and share any changes or thoughts with us in the comment section below.

Other than plenty of bloatware being added with this update, not much else is known at the moment but we will continue to search for more details. Many are also reporting they have not lost root privileges so this should be an update at your own risk type situation. Hopefully this update addresses a few issues the last update did not, and I'm sure further camera improvements would be much appreciated.

As usual you can wait for the update or get it started right now by heading into settings > about phone > check for updates. Let us know if you run into any problems or this update brings about new issues in the process. More details on past updates and problems can be found in our timeline below.

[device id=1476]

[via Droidforums]


Recent Stories
  • Djr4x4

    I have just updated to this new update 5.9.901 and kept root.

    • http://www.androidcommunity.com Cory Gunther

      excellent thanks for the reply. Notice anything different? Other than bloatware

    • TJ Evans

      Are you sure?

      On mine, SU still said certain apps had root access – but they don’t actually have root priv’s.  

      Titanium is broke, uninstall/reinstall == still no root.

      Attempted re-root of phone also fails, “ERROR: adb could not be granted root access via local.prop method” … seems like Big Red has hosed us (or, at the very least, me).
      ((Was trying to use Pete’s Motorola Root Tools v1.06 (filename says 1.07, but oh well) ))

      • Jayson

        I am in the same situation as you.
        Did you find a way to re-root? I am getting the same error as you are when trying to root again, after the update.

  • S3an93

    hhave been trying to update all day but whenever I check for system updates I get a message that says try again later

  • Guest

    I updated a few hours ago, but now the internet no longer works on the phone and the screen randomly turns off long before the set time.  Frustrating.

  • Witchy1

    Got my update last night and now i have the BSOD – pulled battery 3 times, finally came on with a huge battery icon showing 5% – Whats up with this??

  • kemeki

    I’m on 5.5 and get a lovely “Your device is up to date! No update is necessary at this time” message.  Uh huh….

    • brew1

      How can you force Bionic to take 5.9 update; mine is stuck on 5.5.1_84

  • MadMax1966

    Haven’t received the new update but was wondering… I was told the Bionic supports 5ghz band wireless. Is that true? I added the network to my managed networks but it doesn’t connect. Any ideas?

  • Wmf Bennett

    I am on the phone with motorola….they are telling me that only a small number of people received the product update…but someone at motorola told me that they would push the update to me within 24 hrs on friday…..typical with Moto….I’m still waiting…just like we wait for the product and then wait for the update and then the price goes down after we pay full price….last piece of motorola equipment I will purchase

  • http://www.motoask.com motorola droid

    Update seems faster smoother first impressions.

  • Anonymous

    Still haven’t received this update on 12/31.

  • Poetrywaif

    This completely shut of the phone down and it is a brand new Xmas present…Thank you verizon

  • Rustycms

    for 2 days it has told me  me that “check for update ” is not  available at this time  ~ try again later ~I only have build  5.5.1.84

  • lisaellen

    I upgrade software back in December and it did NOTHING!!!  Absolutely nothing!

  • Theresafitz89

    I tried to update last night ans it kept shutting down my phone when it got to 99% and then when it turner back on it would say update failed..any suggestions?

  • Tboles292

    If you recieved a recent update for 5.9.902 The new one click root method will not will. Promise, i just tried it several times, consisted on me having to completely wipe my phone.