iPhone Is Buzz Compatible While Most Android Phones Aren’t

February 11, 2010
0

Now that the “buzz” is dying down for the Google’s new Buzz service, its reality checks time. Currently only 2.0 and higher devices can take full advantage of the new features.

Currently there is only an estimated 28% of Android devices in use that are capable of taking full advantage of these services. This is due to the fact that lower Android versions browser does not support HTML5, although the gears requirement is meet.

The newest version of Google Map’s is only for 1.6 devices and up and this alone rules out a lot of Android’s.  The iPhone on the other hand is compatible with HTML5 and can use Buzz and Google Map’s in the browser. These stats were taken from AndroidAndMe:

Buzz access for different versions of Android:

  • Android 1.5: No Google Maps 4.0, no mobile app
  • Android 1.6: Google Maps 4.0 only
  • Android 2.0+: Google Maps 4.0 and mobile app
  • iPhone: Google Maps 4.0 and mobile app

[via androidandme,Google Buzz]


Recent Stories