HTC Thunderbolt gets the HTCDev unlock treatment

December 30, 2011
5

HTC has been busy adding devices and support for their bootloader unlocking program and just yesterday announced that all devices released after September 2011 are fully unlockable. While this is great news I know there are still thousands of HTC Thunderbolt owners waiting for the real thing too. Today it appears they've updated just that as the Thunderbolt and Incredible 2 have now been added to HTCDev.com and are now truly free.

When the entire HTCDev plan was first announced Thunderbolt owners were very optimistic but now that they've been one of the last added I'm sure most have resorted to 3rd party hacks and unlock systems like Revolutionary to gain access to their lightning packed device. Today both the HTC Thunderbolt and the Incredible 2 can be unlocked with ease.

We know Verizon can't be happy about the news that their 4G LTE devices are being unlocked, rooted, and everything else but it seems that HTC has either come to terms with them or are just staying true to their word and are making this option available for all their devices. With new phones like the Rezound and old phones like the Thunderbolt all getting this treatment I think it's time to focus our attention to Motorola -- who mentioned doing something similar in "late 2011" but we've not seen or heard a word from the big M.

Either way head down to HTCDev.com if you've not already and see if your device is on the list.

[device id=65]


Recent Stories

  • http://twitter.com/nrbovee n.r. bovee

    That’s excellent, although I rooted my TBolt after I got it. Hopefully they release source code so developers can finally access the RIL.

  • bobo

    I tried to unlock my bootloader with htcdev but no luck…anyone else having issues using fastboot oem get_identifier_token?

    • Swantexan

      I’m having the same issues and can’t get any help from support. I just keep getting command error.

      • Curtsr

         I get the same error have you found problem yet?

  • guest

    i cant get it to work either, phone goes straight to hboot no matter what i do.  its like i cant select another of the other options…