Direct Installs for Android 2.3.3. Gingerbread for Nexus One and Nexus S discovered

February 25, 2011
12

Google's warning that the OTA Gingerbread update for the Nexus S and Nexus One might "take a few weeks" to reach all owners was a dash of unpleasantly cold water to the face; happily, xda-developers have dropped by with a hot towel. They've dug up the official links from Google for the Android 2.3.3 update, which means the impatient can now update their handsets without waiting for Google's schedule to notch along.

Two different downloads are available, one for the Nexus One:

http://android.clients.google.com/packages/ota/passion/81304b2de707.signed-passion-GRI40-from-FRG83G.81304b2d.zip

... and another for the Nexus S:

http://android.clients.google.com/packages/ota/google_crespo/e0b546c442bf.signed-soju-GRI40-from-GRH78.e0b546c4.zip

If the links are too slow for you, there's information on mirrors at the original forum post.

[Thanks to everyone who sent this in!]


Recent Stories
  • http://www.s-consult.com Wayne Schulz

    Not working on the Nexus S

  • Linwoodlinwood

    I got a download unsuccessful when downloading the Nexus S one… don’t know why

  • Lizi

    Download unsuccessful on Nexus One

  • http://twitter.com/c_davies Chris Davies

    That’s strange, I’ve just tried the download link myself and it worked with no problems.

  • Kimmitchell35

    I downloaded it with just one problem, the market is the oldmarket

  • http://twitter.com/dilorenzo Fabio Di Lorenzo

    The update supplied here for the nexus s is for the following upgrade scenario:
    2.3.1 -> 2.3.3

    U need another update zip for 2.3.2 -> 2.3.3 (see xda original forum post)

  • Anonymous

    I have noticed a significant improvement in battery life. Can somebody else confirm this?

    I got a huge increase in internal memory too (about 30GB). And the phone feels smoother and more responsive.

    The new UI elements are great….with the exception of the tiny icons in the system tray and the grey on black notification icons (very hard to see).

    I’d like to hear other folks opinion/experience of the upgrade on an N1.

  • 2wheels

    I saw about 15 extra MB’s of free memory on my N1, which went back down to about 10 when marketplace installed the newer version. So far it seems faster as well, and I like the darker colors, so it’s all good as far as I am concerned!

  • Wvex1

    Great (NOT) Got the OTA announcement yesterday. Followed the update instructions. Phone rebooted. Phone version still says 2.2.2. Rebooted again manually. Still 2.2.2. Phone says it system “up to date”. My phone is stock (not rooted). So what gives?

  • Anonymous

    thanks for this. been running it on my n1 for about 18 hours. it’s like having an all new phone. battery is improved significantly, charge times are shorter and apps run smoother. only problem was that i needed to reboot 3-4 times to get all functionality back. you know, things like being able to make calls.

  • Wvex1

    First OTA installation did not work: OTA update downloaded OK. No error message. I installed and restarted (tried restarting a number of times). However, the system info still showed Android 2.2.2, build FRG83G. I have hboot-0.35.0017. My phone is stock and NOT ROOTED. *#*#2432546#*#* just said that “checkin succeeded”. Didn’t see the install package in downloads or at root.

    Now it’s 3 days later. Was too busy the last couple days to manually install. Then tonight I saw the OTA notification again. OTA worked fine the second time. Just FYI for y’all

  • http://www.facebook.com/profile.php?id=749515009 Melanie Bermudez

    I had an OTA update but it didnt download to my phone. I have a Nexus One. It just happened. My phone didnt take to the download. So disappointed :o/