Android Device Manager tracking and remote wipes go live

August 7, 2013
13

Google announced the Android Device Manager a little while back and since then we have seen bits and pieces of the puzzle coming together. Settings began showing up on Android devices earlier in the week and as of today the tracking website has gone live. This isn't the complete setup just yet, but for now you can track, ring and erase a lost device from the web.

Those looking to get started should launch the Google Settings app on their tablet or smartphone. Once here look for the Android Device Manager option and make check the appropriate boxes based on your wishes. There are two options available; the first is to enable remote location and the second is to enable remote factory resets.

The remote location option will allow you to locate your device on a map and also ring that device. And just a brief warning about the ringing, it rings at full volume. With that in mind, you can turn that ring off by tapping the power button (just in case you wanted to do a test ring). Once either (or both) of those options have been checked you can then head to the Android Device Manager website to check the map.

The website is simple and to the point. You will be greeted with details on your device and can also use the little dropdown arrow to switch to others that you happen to have. With the correct device showing you will get a map position of where it is located. In our testing we are seeing accuracy reports of around 10 meters, which is where the ring portion comes in handy. You know, for times when your handset is hiding somewhere in the house.

The Android Device Manager is available for handsets with Android 2.2 or later. Finally, in addition to tracking devices on the web, we are also expecting Google to release a mobile app for on-the-go tracking. That however, has yet to be found in the Play Store.


Recent Stories

  • joe_k

    And once again Google Apps (free) users get screwed?:

    “Google Apps Device Policy is only available for Google Apps Business and
    Education customers. Please log in with your Google Apps account to
    access this page.”

    So often I”m wishing I’d never signed up for Google Apps. So frustrating.

    • Liaw Kim Poh

      Where did you go to get the prompt? I am Google Apps (free) users but it didn’t prompt me when I login to the website. Can track my phone as well, haven’t tried wipe though

      • joe_k

        Oh it appears to be working now! Woohoo! Must have been a temporary thing?

  • Roberto Dominguez

    Not working for me. I see device manager under the google settings app on my Nexus 4 and Nexus 7, but neither device gets located on the site. Ringing or sending notifications doesn’t work either.

    • Mike Kister

      Not working here either. I don’t even get options within the app although the web page identifies my phone.

    • Liaw Kim Poh

      Try check the Location Access in the settings, turn on the WiFi & mobile network location if not

      • Roberto Dominguez

        Yeah I always have that on. Still not working. Probably have to wait for the roll out for it work.

  • Zachary Morris

    Any root users having trouble with this?

    • Zachary Morris

      Nevermind, my unrooted device isn’t working either. Must be a gradual rollout or something.

  • Rick

    Works for me o my two devices

    • Zachary Morris

      What are your devices? I’ve got an LTE Galaxy Nexus (rooted) and an ASUS Transformer Pad, neither of which are getting located or ringing.

      • Rick

        Galaxy S3 and Nexus 4

  • ouma geofrey

    it works well